My OS version is GONE!!!

major7

Registered
Very strange behavior with my OS.

I am supposed to be running OS 10.3.9. I have been for some time. However, this past weekend some very strange things happened with my computer. Yesterday, when I opened up Photoshop CS2, I got a message from that app saying that it detected that I was running a version of OS 10 previous to OS 10.4. I went to the Apple Menu and clicked "About this Mac" to find out what it would say about what OS it is running. Instead of getting the OS version underneath where it says "Mac OS X" (which it still says), I get the Serial Number for the computer!

I don't know where else on the computer to find where it would tell me what OS version I am running.

I decided to try "Software Update" to see if it would detect the need for an OS update. Strange thing there was that it detected fewer installs needed than what I usually get. I usually get a list of about 6 or 7 updates that I never update, because I don't need them, but this time it only showed 3 - and no OS update needed.

I then tried to reinstall the OS 10.3.9 Combined Update from a download I had earlier. When the window came up to choose which volume to install it on, I was not able to select any of the volumes. I don't know if this means that it is already installed or not.

I went to the Disk Utility to see if I could repair anything there. When I highlighted my "Macintosh HD" none of the buttons were enabled. I have a separate partition with an EDrive for Tech Tool Pro. When I highlighted that, all the buttons were at least enabled.

I then booted up with Alsoft's DISKWARRIOR program and rebuilt the volume, but that had no effect.

I then inserted and booted up from the OS X install disk and went to the Disk Utility there. Now the 'Verify Disk' and 'Repair Disk' buttons were enabled, but not the 'Verify Permissions' or 'Repair Permissions' buttons.

Before I go on and bore you with other things that happened with the computer this weekend, does anybody have a clue what i should do next, or where else on my computer I can find out what OS I am running?

thanks,
Steve
 

jer2eydevil88

Registered
The serial number is not abnormal for the about button, however you should be able to click where the serial number is and it should change to display different information. If you click the field until it gets back to your version then you should get OS 10.3.9 again, let me know if that worked.
 

major7

Registered
thanks for the tip, but it didn't work. nothing happened. I single-clicked and double-clicked everything in there and nothing happened. any other suggestions? thanks.
 

jer2eydevil88

Registered
Well you said that "some very strange things happened to your computer this wekeend" could you elaborate more on that? I'll bet that we can find the cause for this problem from that chain of events.
 

MrNivit1

Registered
go back to about this mac. click on the more info button closer to the bottom of the panel. once the system profiler window pops up, you can select the tab that says "software" (should have a disclosure triangle next to it) in the side panel. Once that is clicked, In the main window your system version should be listed.
 

Gig'

Listen2BobMarley
how about using sytem profiler in the utilities folder ? you can also access thru about this mac clicking more info. Then click on "Software" it will display full details of your system check these pics

Sorry MrNitvit for the doubleposting :)
 

Attachments

major7

Registered
I'm not sure what may have been the cause, but here are a few things that happened:

- Probably the main thing was Saturday night I came home and turned on both my laptop and my desktop. (FYI - the problem I am currently having is with my laptop.) Both computers freaked out when I turned them on. The Hard drive on my desktop started making an actual physical grinding noise when starting up. It wouldn't start up all the way. The laptop would not start up all the way either. I got to my log in screen, entered my log in info, but it wouldn't finish logging in. A few of the icons appeared in the upper right corner, but no bar at the top. It stopped there. I then realized that my internet was not working. Well, I eventually got both computers functioning again, but to do so, several times I had to manually stop and restart them.

Some other things that happened:

- I forget which app it was, but there was an app that wouldn't quit or force quit, so I had to manually shut down the computer several times.

- logged on to a wireless network at Barnes & Nobles, but only for a few minutes, since I didn't know it wasn't free. It's the only place I've logged on to a wireless network since I reformatted my Hard Drive. Since I have an older Powerbook, I am using the DLink USB wireless adapter. I've had real problems in the past with it making my whole system freeze up. Don't ask me why I still use it.

- Installed a program from a developer. App is called AppStop. I found it in a magazine while at B&N. His URL is http://developer.mabwebdesign.com/appstop.html. I don't know if perhaps that app caused some problems.

- I also picked up a Practical Web Projects magazine at B&N and browsed the disk that came along with it and installed a bunch of the fonts that were on the disk. Possibly something there was corrupt.

- In order to unzip the fonts, I used stuffit expander. When I did, it said there was a newer version available, version 10, which I downloaded and installed. Every time I tried to use it would just crash. don't know if maybe that was corrupt.
 

major7

Registered
thanks again for all your help.

I tried going to the System Profiler. It actually doesn't say anything about the system version. It just states the Kernel Version, boot volume, Computer name and user name.

I tried this on my desktop, and it gives the System version, so I know I'm looking in the right place, but nothing shows on my laptop.
 

Satcomer

In Geostationary Orbit
Click on the blue Apple, select it and pull up "About this Mac". When the pop up comes up under the bold letters of Mac OS X under it will be some grayed out text (just underneath the bold letters), click on these words several time until the Version comes up.
 

fryke

Moderator
Staff member
Mod
If you read the thread, Satcomer, you'll see that your tip is what he _first_ tried and saw no version number.

I had this happen with an iBook once, although the other way 'round. Mine just wouldn't show me the serial number anymore. Ignored that for a while. Then I exchanged the RAM on the iBook, and everything was fine afterwards. Don't ask _me_ how this was connected.

Either way: I'd do a backup and reinstall at this point.
 

major7

Registered
yeah, unfortunately, I think I may have to do that, although I really don't want to. I don't know how many times I have had to reformat this computer!!! You'd think I'd have it down to a science by now!

I will wait for some other posts to see if anyone else has any other ideas.

thanks.
 

jer2eydevil88

Registered
If the warranty on the mac is still valid I would attempt to let the guys at the genius bar take a swing at the problem. Granted most genius bar employees are little more than salesman you can still find some talented college kids working there if you poke around.
 

major7

Registered
well, that's not a bad idea. My computer is about 3 years old, so it's passed warranty, but it may be worth taking it to them. I would rather spend a couple of hours taking it to them than spending a whole day reinstalling my OS and all my software. Wait a minute, I can reinstall my OS without having to reformat, can't I? hmmm... this problem just got interesting...
 

jer2eydevil88

Registered
If you think you have software problems now and you try a reinstall you could make everything much much worse. That being said it might also fix everything so just be sure to backup EVERYTHING you need before you go down that path.
 

major7

Registered
thanks for all the helpful suggestions. I went ahead and reinstalled the OS, keeping the network and user preferences. Everything seems to working fine again, except the fact that I have to now reisntall Photoshop CS2 because of some missing files.

steve out.
 
Top