Need Help Getting Laser Mouse To Work

Lions

Registered
Okay so keep in mind that to all you Mac people I'm Darth Vader, having only owned machines running Windows or Linux Ubuntu up until about 2 hours ago, so I'm not very familiar with OS X; or Macintosh terminology in general.

I've got an old "Macintosh Server G4" that was given to me for free from someone cleaning out their closet. The thing was essentially wiped of almost everything but the OS and a few basic applications like MS word, all settings are set to default, etc.

I hooked it up and it is working great and is a LOT faster than I expected. Have yet to connect it to the internet but it looks like a breeze.

Anyway the one issue I have- the mouse. The person that gave it to me gave me the original mouse that came with it- a trackball one. Now while I'm impressed by the tremendous speed of this computer, I have no desire to go back in time to the year 2000; I want my laser mouse. :)

The trackball mouse is very difficult to do precise movements with because the ball gets stuck, so other than large sweeping motions its very frustrating. I plugged in my basic laser wired USB Dell mouse that came with my desktop PC though and its even worse. Movements aren't registered, it'll jerk across the screen, and precise movements are even more difficult to make than they are with the trackball mouse! I've tried another basic wired USB laser mouse and the results are the same.
 

DeltaMac

Tech
That may mean that there has been some extra (third-party) mouse software installed.
You may discover what that is, by opening your System Preferences, which should be in your Apple menu. Open the Mouse - or Keyboard & Mouse pref pane, and check to see if you can make a difference simply by changing the tracking for the mouse.
It would help us out if you can determine what you have that might be software that controls the mouse settings. Again, in your System Preferencses, you may also see a pane for USB Overdrive - which is some third-party driver for USB devices, or you may see that there is some Logitech software, like Logitech Control Center, or even (very old) Logitech MouseWare, or possibly Microsoft Intellipoint (which is another driver for mice). Other mouse drivers like that might be helping, or could be working against you... each would have adjustments to the mouse pointing speed.
A trackball can usually be cleaned fairly easily by removing the ball, and carefully cleaning whatever that ball rotates on.
Is the trackball a Logitech - or something else?

I have 3 different Dell USB mice here, and I find they work pretty well. I usually have to turn the tracking speed way down, so they are easier to control.
Another tip, have only the mouse attached - make sure the trackball is not plugged in at the same time. They shouldn't really interfere with each other, but one at a time is a good help when you are trying to adjust the settings, for example.

What version of OS X is installed? Check that under your Apple menu/About This Mac.
That will tell you several things, such as processor speed, and the total RAM memory installed, too.
 

Lions

Registered
Ah, sure enough under "System Preferences" at the bottom there is the "Other" category.

Under this category are 3 things:
  1. Flip4MacWMV
  2. Microsoft Keyboard
  3. Microsoft Mouse

Now under "Microsoft Mouse" there are a bunch of settings for "Microsoft IntelliPoint".

Also my operating system is OS X Version 10.4.11.

I'm sure that's really outdated. ;) This computer is just for my parents to do some basic stuff though without the worry of viruses and such.
 

DeltaMac

Tech
If you are not using a Microsoft device now, I suggest that you uninstall that MS software. You can find the uninstaller in the Applications/Utilities folder. It will probably be named Intellipoint Uninstaller - (surprisingly :D )

You'll probably have to restart your Mac after removing that software. Try adjusting the settings in the Mouse pref pane then. If the Dell mouse is still too touchy (and some just aren't always comfortable with the built-in USB drivers), then some other drivers, like USB Overdrive, or SteerMouse - both versatile mouse drivers - may get the response that you are looking for.
 

Lions

Registered
I'm afraid it still isn't working. The uninstalling process for Microsoft IntelliPoint went smoothly enough, but there now appears to be no distinction between the mouse before and after. I've rebooted and played around with the settings.

I wish I could better describe the issue. It isn't that it's too touchy, like the sensitivity is too high or too low. It's like I move the mouse really hard to the right, and it'll move quickly across the screen like 2 inches like it's working and then just stop moving. Then I have to quickly jerk it to the right again... and again it'll move 2 inches or so and then just stop moving.

EDIT: I've tried this with my one Dell mouse now (wired) AND my wireless Logitech mouse, and they behaved the same, so I don't think the issue is that they are Dell.
 

DeltaMac

Tech
Does your mouse also always stop movement, even if you move the mouse _very_ slowly and smoothly? That is, can you move the mouse all the way across the screen, with any speed (You should not need much mouse movement to move with fast movements, and you would need significantly more distance for mouse movement to move the cursor very slowly all the way across the screen)
Mouse acceleration on OS X is a very different feel, compared to that in Windows.

On the other hand - if the cursor simply stops, while you continue to move the mouse (regardless of the movement speed), then that might not be the mouse at all.

Do you have a PCI card with USB ports? OR, do you have any other USB device (printer, scanner, etc)? Be sure to try unplugging all other devices, even external hubs.
Mac users very often plug USB devices into extra USB ports on the keyboard. Don't do that for this test - Be sure that your keyboard is plugged into the Mac built-in USB, and the mouse is also directly using a built-in USB port. G4s don't have more than 2 USB ports, so that will use all USB ports with those two devices, correct?
 

Lions

Registered
No; smooth and slowly is the movement I'm TRYING to do, but won't work. The only way to get ANY movement at all is by doing these long jerky strokes across the screen. I know that movement is different on Mac and Windows, I've worked probably 100+ hours on Macs running OS X before... but the mouse still functions. It's not like there is an "adapting" period, a mouse is a mouse and it still works in a similar fashion. This is undoubtedly not working as its supposed to though.

I am plugging the mouse into the other USB port, not the one on the keyboard, but it behaves the same either way.
 

DeltaMac

Tech
Have you tried another user account to see if the behavior is the same?
Create a new user account just for this purpose (System Preferences, Accounts pref pane, add a new user account), then log out of your present user, and log in to that new account.
Try out the mouse movements...
Is the movement still intermittent?
 

DeltaMac

Tech
That does help...

Open your Activity Monitor. Move the mouse, and watch the list of processes. click the drop-down menu to change My Processes to All Processes.
Move your mouse, and watch if any processes stop responding - or processor use suddenly spikes, or even RAM memory sudden shows a large change. I don't know why that might happen, but it could be something to watch, as part of the Activity Monitor...

Could be worthwhile to copy files to a USB drive, or flash drive - watching for that copy process to pause, or even fail... built-in USB ports on a G4 tower will be USB 1.1 - so file copying on the USB bus will be really slow.

How much RAM memory is installed?
Do you have OS X reinstall DVDs for 10.4?
 

Lions

Registered
It's saying 768 mb RAM.
No I don't have the install discs.

Do you think there could be an incompatibility issue with the laser mouse being usb 2.0 and the g4 being 1.1?

No sudden spikes appeared in the activity monitor when I moved the mouse around with it open under "All Processes". Is there something in particular I should be looking for.... (I assume this is the equivalent of Task Manager on Windows but I really have no idea what the name would be)?

I've tried transferring files from a flash drive once already and it worked.
 

DeltaMac

Tech
Yes, Activity Monitor is similar to Windows task manager.
I suggest clicking on the header for %CPU, which would sort the list to show the highest CPU use at the top.
I've never seen a USB mouse that needed the bandwidth of USB 2.0 - but possible, I suppose. You said that you tried a different USB mouse.

The file copy to USB is just another test of the USB bus. You'd want to copy a really large file or app - several hundred MB would be nice. Then a folder with a bunch of small files. Your user/Preferences folder would probably fit that description. Copy both to, and from the USB drive. Copy both directions to see if there's any issues.
If there's really no issue with that type of USB use, then perhaps it's simply a driver corruption of some kind.
Best method to proceed is to reinstall OS X - however, a good next step is to download and reinstall the combined OS X updater. You can get that here: http://support.apple.com/kb/DL170

You did say this is a G4 Server (which is simply a regular PowerMac G4, sold configured with OS X Server). Are you sure that the OS X version is 10.4.11, and not Mac OS X Server 10.4.11?
It doesn't really make a lot of difference for your use, but there's a different updater specific for 10.4.11 Server, which is here: http://support.apple.com/kb/DL177
That's just for OS X Server - so download whichever version you need.

The combined updater will sometimes fix odd issues in OS X, as it does a check for all updates, makes sure that everything is installed as it should be, and hopefully can help with strange driver issues.
 

Lions

Registered
Hey... no idea what happened but I restarted a second time and logged back in and its working flawlessly now! :)
 
Top