New Network Users can't login

JimboStormforce

Registered
I have a persistent problem with our Network Accounts at work. I took over here after the server was set up, so didn't build it from the ground up.

The problem I have is that when I add a new network user, I can add them to a group, 'set' their home folder, enable login, do everything you would expect. They appear in the list of network users absolutely fine.

However, every time they try to login, the box simply 'shakes' as though the password is incorrect. If I login to the server as them, that works fine, it's just on a network machine that it doesn't work.

Previous research into this has suggested that it may have been a problem with the home folder creation - however I've checked both the ACL and Posix permissions, and they appear the same as for other users.

Any advice on how to go about resolving this would be gratefully received - we have a new staff member who is limited on the work they can do while I resolve it! I'm not that clever on OSX (recent PC convert!) but learn quickly...

Some more web digging has led me to do a number of things.

I've tried adding a new user (Test User 1) using server.app, and also tried adding a new user (Test User 2) using the Workgroup Manager. Again, both show up in the Network Users list on the client machines, but I can log in to neither.

I don't know if this is a Kerberos issue, and LDAP issue, an Active Directory issue, or quite what, and I'm also not really sure how to investigate the logs etc to find out.

I've also tried unbinding a client machine from the server, and then rebinding in Login Options, but still no joy.
 

Satcomer

In Geostationary Orbit
What kind of server are you using? Meaning the version of OS X Server & clients are you using?
 
Last edited:

nunzig

Registered
Hi JimboStormforce

Did you ever get a resolution to this issue? We have just started seeing a similar thing here.

We have 10.6.8 server (mac mini) as our OD... and when one of our admins created a user account last week, it would not login for love nor money.... over night however it came good and the user was able to login correctly. That was a 10.6.8 laptop.... however today i have created another new user (on the server using WGM) and it won't let the user login on a 10.7.4 laptop.

Hopefully it too will resolve overnight? But this is hardly a useful solution!!

What is interesting is we use Kerio Connect as our mail server. It is on another mac mini...and uses this same OD server for authentication of mail accounts.

Logging into the webmail interface for the user i just created WORKS....so kerio is able to authenticate against the OD...but other network devices can't seem to? The only thing that might be a clue is that the Kerio server is also acting as an OD replica...so "maybe" it is using it's local directory...and getting the records from there, rather than checking with the master? I'm not too familiar with OD.... just guessing at this point.

Anyway, to be clear.... we are running 10.6.8 servers using mostly 10.7 clients...and mobile accounts (but only using local homes, no network homes)

I's love to know if you have had any luck as i have lost this afternoon to this already...and would love to get it sorted!

ciao 4 now

nunz
 
Top