No right click, link highlight or Dock magnification

Gerard McLean

Weird thing happened this morning on boot... Links in Safari don't change to a hand on mouse over, scroll bars, no cursor change, the Dock magnifies, but does not allow me to scroll over to another app.. I have to be directly over the app I want to select, my right click on a 2 button mouse quit working... the highlight on any menu does not appear... ??? what causes this and how I do I fix this?? Completely goofy.. the last update was the 17" graphic display update, but the computer worked fine after install....

Tiger 10.4.2

Preference panel?? Which one? Help...


I will try to help you without all the facts (you need to list the version of operating system when you ask for help). Here is a list of things you need to try.

1. Open Applications->Utilities->Disk Utility and "Repair Permissions" on your hard drive. This should be done about once every two weeks and after big software installs.

2. You may have a bad preference file. Mosey over to your hard drive->Users->your user name->Library->Preferences-> and throw out "".

3. To get down and REALLY specific about your problem, open Applications->Utilities->Console and look at you log and see if an error is popping up and maybe list that.

Note: I am going on vacation and will not be able to help you so someone else here must keep assisting you. Good Luick.
1. OS version was posted in original thread 10.4.2

2. Things have now popped back into working order.. not sure why... tried all of the above before posting....

The problem might be your two-button mouse. I have a Powerbook running the latest version of Tiger (10.4.2). Running it "stock", everything works fine. When I activate my two-button Bluetooth mouse, I see the same kind of problems you describe: the dock no longer magnifies, Expose doesn't work, etc. Haven't figured out how to fix it yet (sorry). Seems like a Tiger bug.
I had the same problem and tried all kinds of things like deleting plist, repairing permissions reboot, change mouse batteries, restart mouse etc...

Symptoms were ... no action of linked items on mouse over, no dropdown menus in safari, no hover color on links, no magnification or scrolling in dock.

Solution ... unplug mouse usb from computer. I am using logitech wireless mouse.

how it works for someone else
This type of thing is extremely frustrating for me also. I'm using a logitech wireless mouse as well, and I think that has something to do with it. The only thing I've found that fixes this is to in fact unplug your mouse and plug it in again. This happens to me at lease 2-5 times per week and it isn't consistent. Happened twice yesterday. I have no idea what triggers it.

Sounds like the one thing we have in common is the fact that it's a wireless mouse (maybe logitech?). I'm running leopard