os x force quit - all icons are folders

billbeemer

Registered
I reluctantly had to force quit OS 10.0.4 on my powerbook and when I restarted all icons are folder icons and absolutely no apps will run - cant change prefs to get into OS 9, aigh! - Anyway, please let me know if there is a "rebuild desktop" so it can find all of its icons and discover that the apps exist. Thank you for your time.:confused:
 

DeltaMac

Tech
OSX doesnt' rebuild desktop like OS9, doesn't need to. Pobably the forced shutdown corrupetd some preferences, hold down option key next time you restart, you will get a startup disk selector, click your OS9 startup, then get to youruser folder preferences and find files that begin with the letters LS, there will be 3 (LSApplications, LSClaimedTypes, and LSSchemes) delete those, restart in X and your icons should be back to normal under X
 

billbeemer

Registered
Does that mean, the OS recreates the "finders" preferences each time it boots? - and if so, could i just load in my back up user files ontop of the current ones? - since moving to OS 10, i have tried to back up my user dir once a week... does the OS not care when the files were created? - and (yes, even more questions) if the files were currupted with the force quit, does the OS write to the pref files on the way out during a proper shut down? Thus making any force quit in OS 10 a bit ugly, unlike OS 9...

thank you very much for your response DeltaMac... I hope to try it out when I get back home this evening.
 

billbeemer

Registered
It worked out great - however slightly different than written above...

With the option key down at start up, the machine could only find the OS X system, this is most likely because what had caused the apps not to run OS X, also didn't allow the computer to recognize the Finder in the OS 9 system directory. However, I went ahead and within OS X I placed above mentioned files (LS***) into the trash and rebooted and WOO HOO everything came back to perfection. Thank you.... I am including this URL in my favorites so that I hopefully will be able to help others as you have helped me.

Happy OS Xin'!
 

jeffg

Registered
Looks like you've got your problem solved, but I just wanted to add a little bit of information. Granted, OSX doesn't use the OS9 desktop file for Carbon/Cocoa apps, but it DOES use it for Classic apps. I've managed to get my desktop file corrupted, and all Classic apps appeared with the generic application icon, things didn't work as expected, etc. Worse yet, rebuilding the desktop from System Prefs->Classic didn't seem to do the trick. After rebooting to OS9 and rebuilding the desktop several times (via Cmd-Opt), all was back in order. Why several times? I have no idea, but after the first time, OS9 wanted to rebuild the desktop the next couple of times I booted. Go figure.
 
Top