Osx 10.2.1 Frozen Cursor



I have a dual proc, 1ghz, G4. Its running 10.2.1...sort of. I have a gig of RAM. I was just about fully updated, somehwere up in the 10.2.8...and then things got pretty bad. I run Protools 001 and Final Cut Pro. The source of problems was updating Quicktime. What a mistake. Anyway, after lots of time I found out that my main problem was an unsupported Core audio issue. I backtracked according to many ProTools/Final Cut users. I reloaded origianl OS 10.2.1...and Final Cut worked again, which was my main issue as I had/have a very important deadline to make. So after all of this backtracking fun...I was up and being priductive again. Then I went away fro a week (lucky me.) I came home last night and started up the box and she went through start up cleanly, and when I got to my desktop the cursor was frozen. So I tried all of the usual things. I unplugged all peripherals, tried again. Nothing. Then I laucnhed via Hardware Test cd...this works fine, mouse works fine...all tests come up good. I just read a thread on this site that seemed to almost almost describe my issues. http://www.macosx.com/content/faq.php/q3101/Mac-G4-Frozen-Screen.html
At the end of the thread, Welton, the patient, responded to Cheryl , the doctor, by saying "thanks, that did the trick." The only problem is I'm not sure what he was referring to...reloading the OS again, or resetting the PRAM on start up. Any thoughts?
Reading the post, it looks like the 'remedy' was both (for this particular person) but you should just try resetting the PRAM first then *possibly* reinstalling the OS - please forgive my hesitance but I'm not sure how non-destructive reinstalling OS X is (with OS 9 it just used to rename the old system folder when you choose the 'Clean Install' option so you could copy preference files and fonts into the new system folder). As another possible fix, it might be possible to boot-up using Safe Mode (or whatever it's called) which can be done by holding down the shift key from start-up until the safe mode message appears when it's loading. More about this can be found at http://docs.info.apple.com/article.html?artnum=107392

At the bottom of this page is a link to more suggestions that might sort out your problem - just go to http://docs.info.apple.com/article.html?artnum=106464

Bear in mind that, if possible, you should try and get hold of an update for these applications because (in software terms) OS 10.2.1 is pretty old. I have OS 10.2.8 and find that nearly all applications, whether commercial or shareware, need 10.3 or higher or say that *yes* their software will run but they'd really rather you had the later OS installed.

In the long term, you could solve the problem by buying a removable hard drive that you plug-in and boot up-off when you want to run ProTools or Final Cut.