PCI Ethernet card needed for 10.4.2 G4 Quicksilver

Mikes3

Registered
Good day;

BTW, I had attempted/tried to post this last night, but I do not see my listing. (So, this may be a duplicate; Please forgive my error.)

As a result of a lightning storm, I have lost my ethernet port on my Quicksilver Dual 1 Ghz Mac.

I'd like to get a moderate PCI card for the replacement function. I see that Sonnet has a Gigabyte card, but this is too nice for my needs, and is close to $100.00, by the time one adds the shipping, etc.

Can someone please suggest a PCI card that will work with my Mac OSX 10.4.2 equiped Mac? (I need sources, model numbers, etc.) MAINLY, it has to work with OSX 10.4.2!

Thank you!

-Mike-
 

nixgeek

Mac of the SubGenius! :-)
Check the Apple outlets online like Small Dog Electronics, MacMall, CDW Mac section, etc. They should list cards that are supported under OS X Tiger. Use Google to find them or even their pricing site, Froogle.
 

ElDiabloConCaca

U.S.D.A. Prime
I used this exact model of PCI card in a G3-upgraded 7600 and a B&W G3 tower. It worked out-of-the-box without needing to install drivers or anything:

http://www.compusa.com/products/product_info.asp?product_code=118210&pfp=cat3

Mind you, I was using it with OS X 10.3.x, but I don't see why it would be different under Tiger. Some users report that their PCI Ethernet cards and 3rd party wireless cards that worked under Panther no longer function under Tiger, but for the miniscule price, it may be worth checking out.

Looks like it's HEAVILY discounted too! Can't beat five bucks!
 

Mikes3

Registered
Good day, and THANK YOU!

I am now in the process of placing an order. It will be here in a few days, and I will report on my progress, especially if it works!

-Mike-
 

Mikes3

Registered
Update: The order has been placed. Thanks! -Mike-

PS: Any possible COMMENTS on this Ethernet card? (Am I wasting my time..?)
I am running Mac OSX 10.4.2, so this is really a very important issue.

I will add that I have installed an Apple Ethernet card into slot 5 of my Dual G4; It does show up, and is configurable. However, I see no "connection" LEDs, and of course, it is not functioning. The PCI card has four LEDs on the back, next to the single RJ-45 connector. (These LEDs as well as the LEDs on my D-Link DI-614 router are not lit for this particular cable's position.)
 

nixgeek

Mac of the SubGenius! :-)
HAve you configured the Network settings in System Preferences for the Ethernet card? Are you getting the IP address dynamically or do you have to manually set it?
 

Mikes3

Registered
nixgeek said:
HAve you configured the Network settings in System Preferences for the Ethernet card? Are you getting the IP address dynamically or do you have to manually set it?
Yes, I did attempt this. (Manual, DHCP, etc.) The Apple Ethernet card does show up in PCI slot 5 of my Mac G4. Almost there. (-But no activity progress.) I went back down to the trusty (?) old G4, and went through the settings again, as you suggested. In no way could I make the port active.

I then decided to experiment...
I took the Apple PCI Ethernet card's cable (installed in my Mac G4), and plugged it into a downstream SWITCH. It WORKED! (The Ethernet cable from my Mac G4 was normally plugged into a port on the 614 router.) All activity on all of the other ports on the 614 router and on the downstream switch were normal and active.

Bottom line: I have -TWO- ports/devices that are dead:
(1) The Mac G4's built in Ethernet port
(2) The port I normally use on my D-link DI-614+ router

This dual failure made the big picture a little less obvious to me. Looking back, this all now seems far too logical.

So now, I have Ethernet connection on the Mac G4, using the Apple Ethernet card in PCI slot 5!!!! Life is good.

=========================================
The saga continues, however...

A hint of troubles, and a QUESTION:
On my DI-614+ router, I have two "status LEDs." (Labeled M1 and M2.)
M1 is on at all times: This is good, per the manual.
M2 is FLASHING: This is indeterminate, per the manual.
-The manual says that if the M2 LED is ON, it indicates a failure.
-The manual has no information on what a flashing M2 LED means.
-The manual states that the M2 shall normally be OFF.
=========================================


So, it looks as is the 614 router is in a limp mode, perhaps. I have completely power cycled the effected equipment. (All units turned off; Modem turned on; Wait two minutes, then turn on the DI-614+ router; Wait two minutes, then turn on the switch; Wait two minutes, then turn on the Mac G4.
(The wait-time for the switch is un-needed, as the Mac is not plugged into this unit, but what the heck...)

Is my router also damaged? (I am assuming so, as the M2 LED has never been active, as far as I can recall.)

At the present time, all of the other ports on the 614 router are good. They all work. The one previously used for the Mac G4 is the only one that is dead on the router.

Thanks, all!!!
-Mike-
 

nixgeek

Mac of the SubGenius! :-)
Now that you mentioend it, if the lightning strike took out your ethernet port, then anything in that connection would also have been fried. So yes, it looks like your router might have been affected as well.
 

Mikes3

Registered
I had reported (in the other post, which had the replies) that I had apparently resolved the no-internet ot Ethernet activity. (In this post: I had a dead Ethernet port on my Mac G4, and also a dead port on my D-Link router! This dual flaw was confusing as I assumed the router was OK.)

However, it looks as if the connection speed (throughput) on the Apple PCI card I now have mounted in my Mac G4 is extremely slow!!

When I reported success before, I had not done any other work other than the "what-is-my-IP" on the web site. This came back right away, so I assumed all was OK.

Bottom line: I do have an ethernet connection on my Mac G4. It is now hooked to a switch, which is fed by the DSL modem. Nothing at all fancy. (I have removed the D-Link router, you see.)

All of the other connections through the switch are normal. All speeds are as expected. Response and throughput is normal with all computers except for the mac G4.

The speed and throughput on the Mac G4 (This is the one with the blown on-board Ethernet port and the slot-5 installed Apple Ethernet card) is dismal. The speeds are slow to the point that even an email cannot be read. (Timeout error...) The what-is-my-IP web site did work, as (apparently) the HTML was small to the point that it did function...

Maybe the reason is that I am using such an OLD Ethernet card in my Mac G4? From the looks of it, this card was designed for a mac PPC 7500 or maybe a Mac II ci.

Thanks again to the group! Your help is greatly appreciated!

-Mike-

Update as of 8AM Sunday, 11 Aug, 2005:
I had reported that I had apparently resolved the no-internet ot Ethernet activity. But, the SPEED that I saw was extremely slow.

Resolution: I had a bad (damaged by the lightning strike?) Ethernet cable! This, in addition to a bad Mac G4 Ethernet port and one bad port on mt D-Link router!

I am now running the old Apple Ethernet card (One Ethernet port and 4 LEDs on the PCI's panel) with a new cable. The new cable now allows me to connect to the internet etc., with all of the expected ease and speed as I'd expect. -Just thought I'd let you know that the old Apple PCI card is doing a fine job (so far, this morning), even if it is 10 or so years old!

-Mike-
 
Top