PHOTOS option for libraries no longer works: Mojave upgrade


After upgrading to Mojave, holding down options>photos no longer offers the choices to the libraries. How do I find them? And is there a way to fix this? I also have photos in external (hopefully) For some reason, the last photo, according to photos, that I put into the photos library was in 2015. Which cannot be the case.
Tried this on my Mojave boot system.
Launched Photos, while holding the Option key. The "Choose Library" window appeared immediately. (?)

I suspect that, as you say, your most recent Photos library is not in the default location. You can see the location of your current photos library in your Photos Preferences. It's listed there next to Library Location.
If you want to try again to choose a different library, make sure that you Quit Photos first, then hold the Option key before launching Photos again.
What happens?
Yeah, I've even rebooted. I did find the "" and I have set that now for the PHOTOS. So, at least pics up to 2020 are showing up. Apparently all my photo libraries are in my Home>Pictures> so I thought there were some libraries on external, but they aren't. I'm afraid to move anything to free up space because I don't feel secure that the photos will actually move from the HD to the External without knowing all the footnotes and asterisks.

Is it also simple to Merge libraries? And if I do, do I just get duplicates of the libraries and then can I choose "delete duplicates" somehow? I know that two of the libraries are partials ie one goes from 2007-2012 and the other goes from 2007 to 2015. But I'm not sure if ALL the photos from 2007 to 2012 are in the library that goes from 2007 to 2015. I've done a "sort of" check but there are 4000 photos. It appears they are (asterisk; footnote) :)
Rebooted again and this time everything took. I get my libraries listed now. My guess is they were large and hadn't completed their journey? So, back to the second half of the question. Merging?
Apple has a support article to combine Photos library files.

You also might need to find (and remove) possible duplicate files. Not sure about a "free" utility, but I used Gemini a couple of years ago. Seems to still be a good tool.
I did download something a couple years ago...I need to check the apps. I may already have something that does this. Thanks.
Well, doesn't "stick." Tried again just now and just launches into PHOTOS.
I guess I'll just have to go to the library each time.
Eh... that's curious!
Are you quitting Photos first, then Option-launching Photos? (You have to make sure that Photos is NOT running - Option does not work unless you are actually launching Photos.)
Just on a hunch, before the Option-launch, bring up the Force-Quit window (Option-Command-Esc). Make sure that Photos is NOT listed in the Force Quit window.