PPP Connect (LCP Failure)


After loading on my iMAC, I can't connect to the internet. It dials, waits, and gets a PPP Connect message , LCP Failure. Anyone figure this one out?
The only time I saw that error was when I was using an incorrect username/password to log in. Make sure you are using the correct ones for your account.

Also make sure that you are specifying the IP addresses of your ISP's DNS servers. Unlike Mac OS 9, Mac OS X doesn't automatically pick these up during the login process.
I have the same problem. I have checked many times all my settings and they are right. I just get the message "LCP failed" after waiting for a while.

I think my USB ISDN modem isn't working with Mac OS X because it doesn't seem to do react in anyway although the PPP application of Mac OS X displays the message "Connecting...". Can anyone help ?

G3/300 Mhz - 224 MB RAM
6 GB hard disk
Mac OS 8.6
Mac OS X (working fine except PPP connections)

I get the same - but only with one of my three ISPs - I have all my settings correct. If you just keep trying again again, about one in 20 connections get through.
I am having all the same problems on X with PPP. I am on a PB Wallstreet 300/192. It has no problems dialing and everything, but not connection. When I listen over the phone everything seems ok, but obviously is not. Anyone have any suggestions? If i ould get this to work, no reason not to preatty much chuck OS 9.

Thanx for the help!!
I've been having a similar problem. I can get connected to my ISP but the browser and email doesn't recognize that it is connected. Perhaps it's a problem witht the IP address.
Please help.
Solved my own problem.
I put in the DSN numbers for my ISP and I can now connect.
In trying, however, I put an address in the IP address window and I got a LCP failure also. So I left it blank and it worked fine.
I hope that helps.
As far as my situation goes with this error it happens no matter what I do in the PPP fields.

Funny thing though, the first night I installed OSX, I did everything I could do. I also got online with no problems. (Although I.E. ran really slow compared to my Internet connection through OS9). Then I felt tired and went to sleep. Like Christmas morning I came back ready for some more exploring. Wallah the LCP failure message came up and does not want to leave!

I do not know if you guys had it work at one point or if it has never worked at all, although to be rich then lose all your money is worse.

I've tried many things, I even went inot OS9 and shut changed the configs in there to see if that would help. I'll keep you guys posted.

...I've had this problem as well. For me, it's followed this pattern so far:

(1) dial in and connect to my ISP without troubles.
(2) Quit PPP Connect
(3) Dial in again, get LCP Failure
(4) Quit PPP Connect
(5) Delete the com.apple.pppconnect.plist file from
(you can do this with the finder without needing to be root or anything.)
(6) Open PPP Connect, reenter all your information (don't forget the DNS infos!)

In an effort to stave off the insanity, I've made a screen-shot of my PPP configuration with Grab, so I can copy it in easily.

The first time you connect, after entering the information fresh, no preferences file (.plist) is created. I believe it is created when you quit and the prefs are saved. Apparently, there must be some mismatch between the saving and the loading of the prefs, because the next time around, when the prefs are loaded from disk, instead of entered by hand, the connection doesn't work.


(* PowerBook G3/300 (Wallstreet II), 192 MB RAM, OS X on separate partition. *)

-- ben
two additions:

- between steps (2) and (3) above, there is some factor missing. Restaring the computer(?) Using Classic(?) I dunno.

- the prefs file is called com.apple.pppconnect.localhost.plist (I forgot the "localhost" bit.)

Tried deleting the pref file....no go......tried connecting thirty times consecitively......cha.......so far osx is a bunch of spruced up windows......have to boot os 9 to get internet.....
Well it's a BEta, at least that is what I keep telling myself. I have so far tried everything from every forum I could find. Deleted Preferences, worked around with the modem files in /etc/ppp/modems (I have put in login and password scripts, also messed around with the modem string) and still can not connect.

I am sure that no one has solved it either, but has anyone tried anything else other than the two main things above.

Ohhhyeah, also tried to dial in and as it is dialing I lifted the reciever for a couple of seconds and then hung up (this was done in many ways too!) but nothing.

The office I work for just installed OSX on one of the mac, fortunately the office is on the network I would normally be dialing into from my home Mac, but unfortunately the office uses ethernet so there is no way of checking the modem scripts or any other files, because it won't help. AHhhhhhh, siiiiiighhhhhhh......

Same problem on an iBook... info in PPP connect is checked a zillion times and correct... deleting prefs doesn't help either. Connect under OS 9 with same data no problem.
My PPP problem is half my info is proveded by my provider. You connect then it grabs all those numbers. Why can't os X do that? Is there a way around it?
fixed my ineternet problems. .stupid me was using the wrong program to connect. i know how dumb that sounds. But it worked fine. i have a dial up 56k connection.


-MN Wild tied their first game ever!-
I too had this problem, and I'm sorry to say I didn't solve it yet...

The first time I tried PPP it worked subsequant tries likely after trying to get Classic to work and possibly rebooting into 9 always yielded the LCP error. I was able to reboot into 9 and dial up no problems.

I'm going to re-enter my settings to see if that helps, but this seems pretty common problem.

I occaisionally have trouble dialing up within OS X still though nothing I can't fix with a retry or two. The most frequent cause is voice mail screwing with my dial tone when I have a message. I had this problem under OS 9, but the LCP problem, I find if I reenter my password and redial it seems to go away.

Also I've noticed you have to specifically launch PPP in OS X then launch IE. But in OS 9 if I select IE from recent apps and run it, it starts Remote Access all by itself X/IE doesn't seem smart enough to do this, at least not right outta the box.


1. Begin by using MAC OS 9
2. Connect to Internet the usual way (aka PPP)
3. Look in your TCP/IP control panel. It should be set for PPP connect. Now see thoose DSN numbers. Write them down.
4. Choose OSX as startup disk.
5. Reboot
6. Now that you're in OSX, go to system preferences, network, TCP/IP.
8. Reboot
9. Start PPP connect.
10. Write in those DSN numbers.
11. Hit connect.

12. There is no 12....

Writing this connected to the internet via MAC OSX and that damn modem.....

by the way, I love MAC OSX
Okay everyone. This has been plagueing many of us for some time now. I think I just found a bandage (not a cure).

If you can connect to internet from OS9 then do so using Remote Access.

After you have successfully connected go to your TCP/IP control panel. If you look inside you should see the IP address that your ISP has temporarily given you, just jot it down.

I hope you know where I am going with this. Restart in OSX go to PPP Connect and fill out the whole thing with your temp IP that you just had a minute ago. It should work.

NOTE: keep in mind that I am doing this on a Saturday afternoon which I know is a slow time for my ISP, considering this I got lucky that someone else did not call in and take the IP, although I wonder if it can be stolen if it is already in use. I'll find out eventually.

But I am gald that finally I am on OSX internet, hope everything runs smoothly from now on. I hope that I can steal IP's because I think if that works I will keep this IP that I used, I figure it will save me from connecting in OS9 everytime I need an IP. I think if stealing is possible (assuming the IP is in use when I try to connect with it) the other person using it gets diconnected, but all they have to do is call back and get a new one.

Any feedback???