PPP Error 246...

Bhende

Registered
Weird problem I have. I keep getting disconnected from my internet connection with a PPP error ID 264. I rally don't understand what it is since it works beautifully through 9.1. And so since I use the Interet a lot for my work, I have to continue using OS 9.1 after buying OS X with such enthusiasm and excitement. I think that sucks!

Please help if anybody can!

Regards,
Kunal.


 

twister

Howdy
PPP disconnected me last night also with some error. i just loged out and back in and i was fine. but i have noticed that PPP is maxing out my computer when it starts to dial out. my mouse skipps around the screen. once it starts dialing then its all good. Whats up with that?
 

Elder Dan

Registered
A workaround that I've heard others mention but have not tried myself: In the network pref panel -> modem -> PPP -> PPP Options, try turning off "send PPP echo packets" and see if the problem clears up.
 

Bhende

Registered
YupI did try that but to no avail. It still just keeps disconnecting me. What I simply don't understand is that if I have no problem with 9.1 why OSX? I'm going really crazy re-booting from altrenate OS's just so that I can cehck mail and surf the net. Yesterday I was connected through 9.1 for over 10 hours without once getting disconnected.

Man, this is frustrating!

Regards,
Kunal.
 

gidds

Registered
Under OS 9.1 (& 9.0.4), the net connection lasts for hours. Under OS X, from PB to 10.0.1, it disconnects at random intervals - sometimes only a few minutes, sometimes the best part of an hour. This is with the internal 56K modem. (Haven't tried the PPP echo fix yet, though.) Extremely annoying. Not only does it stop long downloads, but it can take a couple of minute to 'disconnect' before I can reconnect!
 

AdmiralAK

Simply Daemonic
It has only happened once to me, but I find it very weird. Usually ISPs will disconnect you if you have some sort of idle time, but I was USING my connectiion (actually sending a big long email) and it disconnected me....

Well, things still need to be worked out I guess :)
Patience mes amis...patience! :)



Admiral
 

Dominion

Unix Guru/God ;-)
When you get this disconnect occuring, can one of you possibly pop up a terminal window and run the following:

tail -50 /var/log/messages

and

dmesg

and perhaps post or email the output, this may or maynot capture some usefull info that may help in debugging the problem.

The reason OSX is different to OS9 is that the PPP in OSX is a lot different, there is kernel level support for the ppp networking ability, it's no longer just an application that ties into the TCP/IP stuff, it's a lot more integrated, you're fortunate because ppp and pppoe (ADSL users) are running basically the same code used on Linux/FreeBSD and there is extensive documentation out there on the web for nutting it out. But a bit more info would be handy :)

good luck, A
 

gidds

Registered
It says:
<code>
configd[112]: No response to 4 echo-requests
configd[112]: Serial link appears to be disconnected.
mach_kernel: ppp_ip_ioctl: cmd = IFPPP_IP_VJ: name = ppp, unit = 0, vj = 0, cid = 0, maxcid = 0
</code>(twice)<code>
mach_kernel: ppp_fam_ioctl: cmf = SIOCGIFPPP/IPPP_EFLAGS, flags = 0xf000000
</code>(four times)<code>
configd[112]: [ppp0] sent [LCP TermReq id=0x3 "Peer not responding"]
configd[112]: [ppp0] sent [LCP TermReq id=0x4 "Peer not responding"]
mach_kernel: pppserial_close
mach_kernel: pppserial_close will send event
mach_kernel: ppp_fam_event : EVT_DISCONNECTED
mach_kernel: ppp_ip_event
</code>
(The first line puzzles me, as I've turned 'send PPP echo' OFF in the System Preferences!)

Anyway, hope all that means as much to you as it does to me...
 

Dominion

Unix Guru/God ;-)
hmmm, I have to admit I hate debugging Dialup errors over text mediums..

The output looks quite normal, for a line that has "died".

This can of course be a number of things...

1) Someone picked up the line ?
2) The line got noise or a chop across it ?
3) The line isn't good enough to handle the speed of the link.

It most certainly looks like the line has a problem, but why should it work in OS9 and not OSX ? Well perhaps the default init strings under
OS9 tell the modem to retrain the line differently when encountering noise? Have you checked those sorts of settings line up ?

Have you tried, another modem? another phone line ? Perhaps forcing the modem to connect at a slightly slower speed ? 48000 or 46200 etc etc might work much better. Check you don't have un-nesecary lengths of phone cord, or loops in the cord... Make sure you don't have
other handsets plugged into the line or any extension sockets whilst using the modem.

I was truly hoping for something more obvious in the output of the logs, but as it is.. it's trial and error until you get it right...

lemme know how you go...
Andrew
 

gidds

Registered
I doubt it's a physical problem, as the line works fine with other machines (Falcon, Psion), and with the same machine and (internal) modem under OS9. There's no noise on the line I can hear, and no-one else is interrupting it. It's only a problem under Mac OS X... :(

That narrows it down to either Mac OS X itself, or IE 5.1.1 (updated).

I could certainly try a slower speed... Anything particular I should know re. using Mac OS X/G4 internal v.90 modem/standard UK phone line, e.g. special init strings?
 

bankmann

Registered
It's my guess that a lot of you, experiencing this problem, are owners of dual processor G4s, right?

OS X's ppp-implementation has a bug that is triggered on these machines. In version 10.0.0 and -.1 this could even result in kernel panics. The kernel panics was fixed in version 10.0.2, but the ppp disconnect problem still persists. And Apple is rather reluctant to comment, after what I've read on the MacNN forums.

There is a hack that fixes the problem for some users (by Louis Gerbarg, a carbon developer), but not for all. For some, switching off echo-checks works, but many - as I do - still gets both disconnects and echo-checks.

Another way to fix this is to disable one processor, but does anyone really want to? Not me...

What really makes this rotten is the implied catch-22: To fix I need to download upgrade (if Apple ever gets its rear in gear - Norwegian expression...). But the bug... see?

The OS and the machine that was meant for each other - just aren't. :(
 

Bhende

Registered
Hi there,

Yes, I do have a Dual Processor G4. And to think I spennt all that hard earned money to buy a machine that does not even connect.

So do you think that Apple will come out with a bug fix or do I have to subscribe to broadband access or cable internet which gives me a 24-hour connection. Would that be better than Dial-up? And so I won't get disconnected then?

Well, thanks a ton anyway. Atleast i know what the problem is now.

Regards,
Kunal Bhende.
India.
 

bankmann

Registered
Hi, Bhende!


Well, the ppp-bug is so irritating it's easy to doubt Apple's sincerity in the matter, but arguably this is something they can't afford to let go. Apple hailed the combination of DP and OS X as the thing to really show what the Mac is good for.

So, yes, I do think this bug will be fixed - eventually. It depends on when they figure out what's wrong.

As for going for broadband? Sure, if you can afford it. Just be aware that you really have to think security if you do.

Good luck!


Bankmann
 

gidds

Registered
It's my guess that a lot of you, experiencing this problem, are owners of dual processor G4s, right?

Yep.&nbsp; How did you guess?&nbsp; As you say, this problem is most annoying...

For some, switching off echo-checks works, but many - as I do - still gets both disconnects and echo-checks.

Already tried that.&nbsp; No joy.

Another way to fix this is to disable one processor, but does anyone really want to? Not me...

What really makes this rotten is the implied catch-22:

implied catch-22: To fix I need to download upgrade. But the bug... see?

The solution to this is to download the upgrade in Mac OS 9!&nbsp; Of course, then you can't use (Mac OS X's) Software Update, but previously I've found upgrades on Apple's web site.
 

bankmann

Registered
In reply to gidds:

How I knew is that I own one myself. ;-) I started having disconnect problems from moment one. At first I thought it was my ISP; they'd just exchanged most of their server farm and dial-up connection hw. Then I started checking out the origins of the error messages. And started browsing a lot of OS X related message boards.

All of us DP owners with OS X have this problem.

As for updates, Apple needs to realise we don't want to wait a month or two before they reluctantly make them available on the Web or via ftp. I never even saw 10.0.2 before I found it on a Mac enthusiast's home site...

I'm following the news about releases closely now, but so far there's only been wild rumours about .4 and .5, and nobody knows enything about whether the bug will be fixed or not.


Bankmann
 

drewbert

Registered
Well, now that I've got 10.0.4, it's stopped disconnecting by itself.

Now, I have to click "disconnect" all by myself every time the connection suddenly stops working.

:mad:
 
Top