Printing Problem


I'm running MAC OS X 10.3.9. Just today I attempted to print a state map of counties from Adobe Photoshop, and received: "Could not print "file" because there is not enough memory (RAM)."

I tried the same in MS Word (office 2004) and received the message: "Word cannot print due to a problem with the current printer. Make sure you have printer selected in Print Center. You may need to print again or adjust your settings".

I dont have an overabundance of programs running, so I dont know that memory is really an issue?

I'm not sure why this is occurring. Im part of an office network, connected to the printer. THe only thing I can think is that I was fixing a boss' ability to print just yesterday and somehow "Share My Printer" was selected. I was seeing "Shared Printers" as choices for my printer, and this never happened until today. Any suggestions on how to get my printing back? Thanks greatly!!
Im running the newest version of Mac OSX and have 2.5GB of RAM installed. I am receiving the same messages and am unable to print.

My CPU is on a home network, using a shared HP1500 printer. this set up has been working without problems for the past year.

Does anybody know what is causing this problem and how to resolve it????

I think I'll try turning it off then see what happens.
What's interesting is I was printing from word fine just last week. The only thing I've done is update OSX to 10.4.9 and printed from safari (the printer jammed but then printed fine.
Another quirk was that earlier this morning when I got this very mesage the printer printed a doc from over a month ago!
Thanks Satcomer :)
Sadly still no joy.
This would appear to be an MS Word only problem as I'm printing other things without fail. Maybe it's time to go neo office native ;) Trouble is a friend has asked me to print something made in MS office and it looks lousy in neo office.
I'm having the exact same problem ever since I upgraded to 10.4.9 but only on my Intel Macbook. I can print from every program other than Word and Adobe Acrobat won't boot now. I would move to NeoOffice but Word doesn't look right and I can't get Bookends to work well. I have updated the CUPS, reinstalled the printer software, reinstalled Office, fixed permissions, etc. - nothing has worked.