Problem Reading Some Dvds. Dvd-r's Burn But Can Only Be Read On Another Machine.

sgould

Registered
I have a 2010 iMac desktop and a 2012 MacBook Pro. I have had both from new. I have burnt and read CD's and DVDs on both. Both are running the latest version of El Capitan v10.11.6

Today I have a odd problem. I burnt some files to a DVD-R on the desktop. When it completed, it verified OK, but it did not appear on the desktop as an image. I ejected the DVD with the keyboard button and reinserted it. It appeared on the desktop as "Untitled DVD". When opened, it appeared to be blank, with the words "Recordable DVD" in the window. No files were listed.

I took this DVD to the MacBook Pro and inserted it. It opened and all the files were listed correctly and the contents were there. So the iMac is writing DVD-R discs, but not reading them.

I needed to make two DVDs, so I did the second one on the MacBook Pro. When that had finished burning, the icon appeared on the desktop and could open it and read all the files. I took this DVD back to the iMac and it also appeared as "untitled DVD" and no contents showed when opened, just the "Recordable DVD" in the list.

I tried to read some more DVD-R that I had burnt on the desktop in the last couple of years with the same result. They had previously worked on this iMac and they were burnt on it. I check all the discs that I burn before storing them. They all work fine on the MacBook Pro.

Finally I checked some other DVDs that I had burnt on the iMac. These were CD-R, DVD+R and DVD+RW DL. As well as checking some burnt discs that I had been sent. They all appear on the desktop and open and work. So do some original manufactured DVDs which are not burnt copies.

Why won't the iMac read DVD-R discs that it or the MacBook Pro have burnt, yet read all other formats. Even though the older DVD-R that were burnt on it used to work on it?

I don't have any unused DVDs in formats other than DVD-R at the moment to see if it is just that format that's going wrong.
 

Cheryl

Rosie Moderator
Staff member
Mod
A hiccup? Have you tried restarting the problem iMac? It could be the software to read it is having a tantrum.
 

DeltaMac

Tech
Yeah…
Unfortunately, the slot super drives that Apple has used are just not known as the most reliable in the world…
They may break down with a variety of symptoms.
Reading is a different hardware function from writing on optical disks, so what you experience now is just a symptom of a failing DVD burner.

I did not read in your post that you tried cleaning the drive?
A good shot or two from a can-o-air may help.
You can also try a cleaning disk. That's the kind that has the tiny brushes imbedded in the disk surface, or even a wet cleaning surface of some kind.

Finally, your iMac is a couple of years older that your MBPro. I lost the dvd function completely in an optical drive 2 or 3 years ago, and simply ignored that Mac when I wanted to burn a DVD. I have 2 others that have built-in drives, plus a couple of USB burners that I can just plug in to whatever I need.

One more thing, the superdrive on a 2010 iMac is not difficult to replace.
You can find brand-new replacements for less than $30
 

sgould

Registered
Thanks. I'll give it a clean first, and see. I was a bit wary of that because I used a cleaning disc on the DVD in my car. It went in but wasn't recognised, so the eject button didn't work.
 

DeltaMac

Tech
Yes, I agree.
Those cleaning disks, because they may not have a data track that your Mac will recognize, and might won't mount. But, will spin a few times, which is the goal. You might not be able to do a normal eject - BUT, a force eject may run the eject mechanism anyway.
If the cleaning disk does not eject in a normal way, just restart while holding the mouse button down. That usually forces the hardware to try to eject, even if nothing is in the drive.

To be honest - I always mention a cleaning disk, but I have not personally ever seen improvement on a drive that was already struggling. I have disassembled hundreds of Macs - worked in a service shop for a dozen years. I typically will do a full cleanup by taking the drive out, and opening the drive itself to clean, inspect and lubricate (if needed). You may not have that confidence to go that far, but your 2010 iMac is not particularly challenging to open for service.
 

sgould

Registered
Cleaning disc didn't make any difference. :( But it did eject!!:)
 
Top