Problem Setting Up Icloud After El Capitan Upgrade

sgould

Registered
I set up El Capitan on our desktop 2010 iMac last month. I thought that all was well. But there's a problem.

There are two users on the iMac one user is mainly for my wife's work and general stuff. The other user is solely for some of my stuff and synching my iPhone.

The general user area works fine, iCloud is set up and my wife's iPhone 5 will sync with no problem. Connecting to iCloud via the System Preferences from that user is OK too.

My user section will not connect to iCloud, nor will it sync my iPhone. My phone is an older 3GS.

When trying to sync the phone, I get a message saying that there is insufficient memory (There's 330 GB free!). I have looked for help on line and found the recommendation to reboot the computer and the iPhone - I've done that - and I have also cleared the "Lockdown" folder in iTunes. Phone is recognised by iTunes, starts the sync process, but fails, with the "no memory message".

When I try to connect to iCloud via the System Preferences inside my user, it goes through the motions and then says there is a problem with the User name, and to go to System Prefs. It just goes round in circles. Also, each time I enter my area, I get asked to set up iCloud. I go through the screens and agree the T&C's, then it shows the same fail message.

Restarted, Verified Disc, Deauthorised and Reauthorise computer nothing is sorting this.

In a standalone situation my iPhone works and connects to iCloud. Find My iPhone works, as does everything else.

Any ideas?
 

Cheryl

Rosie Moderator
Staff member
Mod
Give this a try:

Go to Your home>Library>Application Support and trash the iCloud folder.
Go to home>Library>Preferences and trash the com.apple.ids files.
Go to Keychain Access and trashed all the keys related to icloud.
Restart and then empty the trash.
Now go to system preferences>iCloud and sign in.
 

sgould

Registered
Thanks for that. :)

I'm now into iCloud, but still having no luck with the iPhone sync. But I'll run through the Lockdown removal again and do another restart. It's well after midnight in the Uk and I may have done something in my sleep!!
 

sgould

Registered
I'm beginning to wish I hadn't upgraded... :(

The iCloud issue is not fully resolved. The main user section works as expected, as it has always done, but my own section is not right. It does let me log in to iCloud now, but every time I swap into my section for the first time each day, it goes through the whole set-up procedure and takes ages. The Dock has reverted back to the original from the last OS, with "?" in place of the missing apps - iChat, iCal & iMessage. I delete them and put in the ones for "Calendar" and "Contacts". But nothing is saved. There was a very brief message about be unable to repair permissions, but it only flashed up.

The iPhone will still not sync.

And I've spent the last couple of days getting the older Canon 4400F scanner to work. Reinstalled the original 2011 driver and use VueScan. So $20 and it allows the use of the flatbed scanner, but not the transparencies.

Quite disappointed really. :(
 

sgould

Registered
Thanks for the links. It's improved a bit. I ran through the suggested method twice. I still get asked to login and set up iCloud each time I enter my user area, but it does it quickly without waiting an age between steps. So something has changed. Still no luck with syncing the iPhone and the Dock reverts back to the original each time I re-enter the site.

I think that the only way forward is to save all my data. Delete the user and set up a new user. Do you see any problem with that? Maybe for safety, I will set up the new user before I delete the old one!
 

Cheryl

Rosie Moderator
Staff member
Mod
Save your data, etc, create a new user, then test it out before deleting the troubled one.
 

Satcomer

In Geostationary Orbit
sgould Maybe you should run the free application EtreCheck and see what is no longer compatible with you new operating system. The program will show you the path to delete/update files, plugins, etc to see if some old plugin is interfering.
 

sgould

Registered
Thanks, I'll try that later.

It just seems odd that one user has been fine and the other user is having problems. The second user is only used occasionally and has no apps or anything that isn't shared. It's just used as an area for managing and storing data and back-ups from a couple of websites that I have ended up helping to run.
 

sgould

Registered
Set up a new user and that is all working as it should. I'll transfer over the data I need and delete the old user. I'll do it bit by bit, and check after each stage, in case something in the data is the problem.

Still no clue as to what's up with it. It just won't save any settings...
 
Top