problems formatting NTFS drive

Tetano

Registered
Hi guys,
a friend of mine bought a Maxtor 160 GB external drive that was supposed to be OS X friendly, but when she first plug it in her iBook, she found that was NTFS formatted.. with another friend, she tried to format it from disk utility, booting from her internal drive and from the cd, trying first to unmount the volume and then initializing it, but without results. a similiar problem is described here...
yesterday evening I was able, giving her the commands trough msn, to partially sove the problem using the terminal... what I told her to do was:
1. once identified the volume on the drive she want to erase using:
ls /dev/rdisk2* ( -> rdisk2s1)
2. I told her to unmount the volume:
sudo diskutil unmount /dev/rdisk2s1
3. then I told her to create a new HFS volume on that partition
newfs_hfs -v HFS_VOLUME_NAME /dev/rdisk2s1 (I don't remember the name of the volume she decided to use...)
4. to mount the partition,
hdid /dev/disk2s1

and it works....
but now the volume doesn't mount automatically when the drive is plugged in the iBook, and she has to type the last command to use the volume...
so, two questions:
1. were that commands correct for that problem?
2. more important, how to make the mounting of the volume automatic?

thanks!
 

ElDiabloConCaca

U.S.D.A. Prime
Now that she's got the drive in a Mac-readable format, why not try doing another partition/format with Disk Utility? I'm thinking that some format command for auto-mount didn't get written to the disk when she formatted via the command line, and reformatting via Disk Utility may help remedy that.
 

Tetano

Registered
We tried, she was able to set all the options (format, hot to erase,...) but when pressed erase, a icon popped up saying there was an error... do you think that we have to unmount the volume to format it via Disk Utility, or not?
 

ElDiabloConCaca

U.S.D.A. Prime
No, Disk Utility will automatically unmount a disk when it's formatting it.

The only thing I can think of is that it's either an incompatibility with OS X, or that the drive is damaged, which is unlikely since it'll work fine on a PC, right?

Strange... some Maxtor drives have "alternate" jumper settings for times like this -- it may help to crack the case open and fiddle with the jumpers.
 

Tetano

Registered
Thanks for the suggestion, but I think that it's better not to ask her to open the case, I don't think she's able to deal with jumpers and things like that... and I can't phisically help her, 'cause she lives 700 km away from my city... I think that she can use it as it work now until her pc come back from the assistance, and then use the Maxtor software for format the drive in FAT...
thanks again for the suggestions!
 
Top