Safari doesn't work

cbrooks3

Mac Nerd
I went to the local apple store Friday night like all the other hardcore mac geeks in the city and bought Panther. I was psyched! But once i got home, things changed. After falling asleep waiting for all the languages to install, which I can't speak any of them, and then finally logging in, i wanted to find out about everything. The one thing that caught my attention in all the ads was the fast user switching. But Apple forgot to mention one thing, it is REQUIRED that you have a quartz extreme compatible machine to have it do the rotating cube thing. OK. not the end of the world. But now my Safari doesn't work at all. After repairing permissions and re-downloading Safari from Apple's website, i find out the installer for Safari doesn't work in 10.3 YET. The guy at the Apple store said he has never heard of such a problem, has anyone out there? I'm dying sitting here using IE. It's painful after 3-4 months of Safari.
 

DeltaMac

Tech
What do you mean by 'Safari doesn't work'?
error message?
crashes immediately?
nothing at all happens?
Just won't browse

Not too hard to fix, delete the Safari on your system, re-install Panther, choose to customize the install (you don't have to install any foreign languages, or extra apps that you don't want to upgrade.) Safari is part of the basic system install, and that should get it to work (unless you did a straight upgrade, which most here do NOT recommend, the archive and install option seems a better choice)

OR, Camino, or Firebird, or Mozilla all work great in Panther. :)
 

Roadie

Registered
hey, did you ever get this fixed? i am having the same exact problem...ny safari just refuses to work. It just wont load any pages...doesnt time out either, just sits there trying to load.
 

Roadie

Registered
thats weird, because the version of safari i have is FROM the panther cd...? i guess i will try and reinstall it.
 

twister

Howdy
We have the same problem. What the heck?! Has anyone found a cure? Safari starts up but won't load any pages. No error messages no crash, nothing. IE works fine however and so does software update. This is just minutes after a clean install of 10.3.

We need help please.
 

Cheryl

Rosie Moderator
Staff member
Mod
Twister,
Go to Disk Utility and verify and repair permissions. After an install, you need to do this. Just Panther's way of protecting your computer.
 

Cheryl

Rosie Moderator
Staff member
Mod
Go to Home>Library>Preferences. Trash the com.apple.safari.plist. Empty the trash. Launch Safari. See if that works.
 

twister

Howdy
That didn't work either. However, i checked software update and i kept telling it to install software and it would do nothing. so i created a new user and safari and software update works there?!

Now my new question is, how do i create a new admin user? I'm gonna just say screw the user that can't use safari and start a new one. But it needs admin privileges.
 

quiksan

awesomer...
i had a similar issue.

for me it was a bad font(s). basically, you need to strip it down to your base fonts that os x comes with (assuming you've installed additional fonts), and then try.

I basically had to add the additional fonts back into my /library/fonts/ folder 1 by one and test safari each time to see if it worked. total pain the butt. but it worked.
 

BitWit

Flash/JavaScript nerd
I have 10.3 and I've been using it for about a month or two, but then starting yesterday, my computer is completely locking up and giving me blocks of text overprinted on the whole screen. SCARY!

I have Xupport, which does all the usual maintenance/cleaning tricks, but no luck.

I've switched to Mozilla Firebird (which I like), and its seems to have helped.

But I still am worried because I never fixed the problem. Also my Software Update is not working... it contacts apple, loads a list, says I need to update, but doesnt show anything.
 

twister

Howdy
quiksan where have you been? :) That was the EXACT problem. We opened font book and it had a font named ??????? so we deleted that out and safari worked again. THANKS!!!

Also amazingly font book opened 450 fonts in seconds on his G4 400!! OMG that's fast
 

BitWit

Flash/JavaScript nerd
Im starting to think my problems are on a deeper level. Just had the freeze-up with overlaid lines of text in Mail
 
Top