Set default wifi network?

Matsaki

Registered
I have 2 networks in my house. One router from my ISP and after that my Netgear WRT3500L. I don't wan't to disable my ISP router as I use it sometimes.

But every time I restart or wake up my MBP it connects to the ISP router. Is there a way so I can set my Netgear to be the default router?

Many thanks!
 

DeltaMac

Tech
What problem results if you accidentally connect to the "wrong" network?

Do you have the network from the Netgear set as your default network?

Open your System Preferences, then the Network pane.
Click the Advanced button.
If your Netgear network is not at the top of the list of "Preferred Networks", drag that network to the top. Click OK
Click the "gear" at the bottom of the network list, and choose "Set Service Order". Drag Wi-Fi to the top, if it is not already at the top of the list. Click OK, then click the Apply button.
 

Matsaki

Registered
What problem if connect to "wrong" network? I have to change each time as I want to be connected to my Netgear (if I understood your question)

I have Netgear at the top of the list etc. But still it connects to the ISP router first. I guess my computer recognises the ISP router first, and therefore connects to it. But I don't think there is a way to fix that. But I wanted to ask.

What problem results if you accidentally connect to the "wrong" network?

Do you have the network from the Netgear set as your default network?

Open your System Preferences, then the Network pane.
Click the Advanced button.
If your Netgear network is not at the top of the list of "Preferred Networks", drag that network to the top. Click OK
Click the "gear" at the bottom of the network list, and choose "Set Service Order". Drag Wi-Fi to the top, if it is not already at the top of the list. Click OK, then click the Apply button.
 

DeltaMac

Tech
Sorry, my question was poorly expressed....

If you NEED both networks, why is there a problem if you connect to the wrong one?
I'm guessing the Netgear provides an internal network (maybe with a proxy server), and the ISP router is outward-facing?

Is the ISP router a stronger signal? That should be an easy fix.

Or, have you tried setting up two network locations that each default to the different router?
Having locations that are not on the "Automatic" location, and with configurations that use each router specifically, may help your Mac connect first time to the "correct" router just by switching Locations.
In other words, setup one location that is "Netgear" only. You could leave that set as the normal location.
Change to "ISP" or whatever you would call that - when you want to change over to that router.
 
Top