Sims 3 game won't start-- help :(

#1
I got a brand new macbook pro in May and have been playing the sims 3 on it with no problems for months. Yesterday i got 2 new sims 3 games- the generations expansion pack and the world adventures expansion pack. I installed both of them and when i tried to launch sims 3 generations it said there was no disc and to insert sims 3 pets which i also have. It didn't make sense to me because the generations disc was in fact in there and i didn't understand why it was asking for the pets disc. This also happened when i tried to run world adventures. so i uninstalled generations and adventures, and now when i try to launch sims pets a window comes up that says

"Failed to create symlink
/Applications/The Sims 3/localized/The Sims3.app/Contents/Resources/AddOns/The Sims 3 Pets.app/Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3 World Adventures - > ../../../../../../../The Sims 3 World Adventures.app/Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3 World Adventures"

Can someone help me? I'd appreciate it. I'm sick with the flu and I have to stay in bed for a few days--- The Sims was my main source of entertainment!!
 

Giaguara

Chmod 760
Staff member
Mod
#2
The parts listed are missing. To have been able to create the links it would have needed those discs.

Did you rename any Sims folders, or move the Sims applications to any folder other than in which they were first installed (or /Applications if it didn't need an installer)?
 
#4
An accidental move may mean that you moved the game into a folder, and now you can't locate it.
Do you know where it is now? Use Spotlight to do a search for Sims, if you have simply misplaced the app.
Did you try moving the game back to where it was originally installed?
 
Top