smbup samba3 sometimes recurently rejects valid username and password

Shameem A Salam

We are using Mac Server and Windows clients. As known the Apple’s OS X’s native netbios and SMB services are really buggy we find SMBUp. SMBUp installs Samba, which in turn replaces Apple’s OS X’s native netbios and SMB services.

After that everything goes fine connectivity is become stable.

But the problem is that some user gets disconnected rarely and after that they can't connect back.

Windows shows the error message Username/Password invalid when tried to login. I tried many ways to solve when this situation arises but nothing including restarting the server worked.

But only one way just create new user and add the user to groups and enable the samba password can used as temporary solution. And after sometime ,a day or more that invalid username works.

I think that, this kind of issue may cause when our employees tries to connect the share using same username from different PC's.

I tried many fixes for windows and tweaks for Mac Samba. No change.

when I checked for the logs it also shows matchname: host name/name mismatch.

Even now in some day's its causing too much headache for me.

Please Anyone Please Help Me...