Snow Leapord(10.6.8) no longer booting in 64bit

exodous

Registered
So I'm at my parents house and updating their mac, not to a new OSX version just mac updates and programs, and noticed a ton of software stopped working with this coming up(VLC as an example):

You can't open the application VLC because it is not supported on this type of Mac.
VLC worked yesterday so I googled and it appears that I have the 64 bit version installed and now the mac is booting into a 32 bit kernel. I confirmed this by typing:

Code:
uname -a
into the terminal. I held down the '6' and the '4' on boot but still boots up in 32 bit. I backed up with Carbon Copy Cloner and went to check to see if the backup worked by holding down 'u' on bootup(to boot from USB) and it wouldn't boot from USB. This has always worked in the past but is a no go now.

I've updated a lot of programs and they all worked even after turning it off the other night. I think the only 'weird' thing I installed was DVDFab for OSX, everything else I updated was through Apple's update or were all open source software like VLC and Handbrake.

So I have two problems, it is booting into 32 bit and holding keys down while booting up won't affect anything. Any ideas? I was thinking of upgrading to Mountain Lion for them, is there a way to force install that as 64 bit and fix the 'boot options by holding keys down' problem?
 

exodous

Registered
I'll give it a shot but I think their install is borked, still wouldn't be able to boot from USB by holding down the 'u' on startup.
 

DeltaMac

Tech
Right-click your VLC app, and choose Get Info
VLC would be an Intel Application, versions 2.0.3, and should have a box in that Get Info "Open in 32-bit mode". Check that box, close the info window, and try to open VLC. Does it open now?
Finally, booting into 32-bit, or 64-bit kernel should not affect using 32-bit or 64-bit apps, as most are coded to be used either way. The purpose for the 32-bit selection (in that case of VLC) is to force the app to open in 32-bit, usually to give compatibility for specific plug-ins, or for other software compatibility. The OS X really doesn't care which bit-mode an app wants to use (generally speaking)
Do you see anything different in the info window, that doesn't seem to agree with what I said?
BTW - I can download the 64-bit only versions of both Handbrake, and VLC. My MacBook is 32-bit kernel only. Both 64-bit apps open just fine in my 32-bit system. It's suppose to work that way.

Another answer - Holding the "U" does not provide a method to boot to a "USB" drive. Hold the Option key during boot, and choose the partition that's on the USB drive, and then press enter.
Option will work.
"U" does not (never did!)
 

exodous

Registered
Oh gosh, that is how I booted from the USB drive, I guess I got confused. Not a mac user, just help my parents with their's.

Ok, so I downloaded the 32bit version of both VLC and Handbrake and now they both work. I have no idea why they are acting like this but trying other programs that I've updated work fine like firefox and openoffice(those are 32 bit only I think). I know that the 64 bit versions worked fine yesterday and the only thing I did since then was install DVDFab today.

I tried the 32 or 64 bit startup selector that SGilbert pointed out and it says the mac can not use 64 bit, it is the last iMac in a white case, I think the first Intel Mac.

Oh, and I did not get the option in the VLC info to force it to 32 bit.

I'm here for a week and want to get this resolved before I leave so they aren't calling me up asking why things are not working. Everything else I tried is working however, maybe it was just VLC and Handbrake but since it should run both 32 and 64 bit side by side I'm confused as to why it does not anymore.
 

DeltaMac

Tech
No, I did not say that you can run 32-bit and 64-bit apps side by side.
If you have a 32-bit only app, it will run.
If you have a 64-bit only app, it will run, also.
The main difference between booting to a 32-bit kernel, or a 64-bit kernel for those apps, is that the 64-bit kernel provides simple access to LOTS of RAM memory, and, the 64-bit kernel may have better performance as a result, often because of better use of memory.

Just for your info, none of the white intel iMacs will run Mountain Lion.
It's not just one model.
Depending on how you count, there's about 5 models of white intel iMacs. The oldest (Core Duo from early 2006) do not have capability for booting to a 64-bit kernel.
 

exodous

Registered
Well, it is good to see that there is nothing wrong with it and for some reason the handbrake update and the VLC update just messed up and sent me the 64bit update, that was odd. I thought I seriously screwed up their computer. When my brother moved out, the youngest, no one was nagging them to buy a new Mac but I don't think they really need a new one for what they use it for.

Well, thanks for the help, I'll come here next time something goes wrong.

EDIT: Oh wait, I missunderstood your post, I guess there might be something wrong with their mac since it can't run 64-bit apps? I know on my Linux box if it is installed 32 bit 64 bit code won't run but if it is installed 64 bit it can run 32 bit. Macs aren't like this?

Installing the 32 bit apps fixed it, is something wrong with it if it can't run 64 bit apps? I might still have a problem.
 

DeltaMac

Tech
No, Macs with OS X can run 32-bit apps equally as well as 64-bit apps. The system itself is 'ambidextrous' - or I suppose you could use the word "omniscient"
There is no "special" install to make OS X 64-bit (or 32-bit, for that matter) as there would be for some other OSes.
 
Top