Sonnet Tempo Ata-100 In Beige G3


Hello. I recently installed a Sonnet PCI Tempo ATA-100 card in a slot on a desktop beige G3 in hopes of mounting 2 additional internal hard drives. I was told that only one drive (the main drive of the machine right now) which resides on ATA bus 0, is mountable, and therefore to mount the other 2, the solution is the PCI card. So... I set one drive as master and one drive as slave, cabled accordingly, and connected to the card. Upon restart, the machine doesn't boot. (Blank, lit screen with cursor only) I tried booting from system cd thinking maybe the drives need to be identified/formatted/etc., but cannot boot from cd either. One drive is 6gb with OSX from another machine, and the other is new 80gb Hitachi, never used. Main hard drive is 20gb Seagate which boots using OS 9.2. I disconnected the cable from the card and system restarts as normal. Any help greatly appreciated. Thanks. Scot.
One drive should be on the on board IDE Controller set as Master. Second drive should be on the Sonnet card set as Master.
It sounds like he's got 3 hard drives -- the one connected to the internal bus, and two additional hard drives.

You should only jumper the 2 drives connected to the Sonnet card as Master and Slave if you're using one ribbon cable to connect them to one port on the ATA PCI card. If you're using both ports on the PCI card with one cable each going to two hard drives, you should jumper both of them as master.

Short answer: if you've got one ribbon for both hard drives, jumper as Master and Slave (master for the drive connected to the center ribbon connector, slave for the drive connected to the very end of the ribbon cable). If you've got two ribbons, one for each hard drive, and they're connected to two different buses on the PCI ATA card, jumper both as Master.
Yes, three drives exist. The two on the card are on one ribbon cable and the 6gb is set as master. and the new 80gb is set as slave. I believe I have the master at the end of the cable and the slave on the middle connector, as I was told is the correct configuration, although I'll have to double check. (It's on this machine so I have to shut down and take it apart) Thanks. Scot.
While some computers work with either the master or the slave connected to the middle connector and end connector, some require a specific configuration.

I double-checked and Master at the end of the ribbon cable with the Slave on the middle connector is correct.

It might also help to check your drives to see if they have "alternate" jumper settings (some Western Digitals have alternate settings for Master and Slave for system compatibility problems).
Thanks. I'll check the jumpers later today. I also researched the connection positions and found that Master is at end on 80 wire ribbons and middle on 40 wire ribbons. Check this link to confirm me:
So... I have to be sure of 80 vs. 40 on my cable also.
Even if the cabling is correct, it seems the unit freezes up due to not knowing which drive to use for a boot OS. The peculiar thing is that I couldn't even force boot fron cd via holding "c" key at start-up. Thanks for your interest. Opinions and thoughts continue to be appreciated. Scot.
Two more suggestions:

1) See if the computer will boot with only the 80GB drive connected to the PCI ATA card, then repeat with the 6GB

2) Grab another cable, and see if it'll boot with the 6GB on one of the PCI ATA's busses and the 80GB on the other bus, both jumpered as Master

This may narrow the problem down to a single drive causing the problems (as per 1), or possibly the use of them in a master-slave config (as per 2).
Nice suggestion. The PCI card has two available slots, each supposed to support two drives, for four total. So you're saying that if I set both drives to master and connect to card on each of the two sockets, I may see them independently rather than in a chain. I guess they both belong on the end connector(s) also, right? Also, you don't think it's an OS "confusion" issue with these drives? Thanks again. Scot.
I'm thinking it's more along the lines of a hardware incompatibility somewhere rather than a software incompatibility, since your machine will not boot at all. If the computer was simply confused about which drive to boot from, and all hardware was compatible, you would see a grey screen with a disk icon and a flashing questionmark over it. Since your computer isn't even getting this far, it sounds like it's choking early in the power-on stage with some hardware compatibility.

Some drives just don't like to be master to a slave or slave to a master with certain other drives -- like if you're taking a relatively old drive and chaining it with a relatively new drive... one of the drives might "complain" a little in that scenario, or refuse to be a part of the chain with the other drive altogether no matter what you set the jumpers to.

Will the machine boot from the internal hard drive with NO drives connected to the PCI card? That's one more thing to try to see if it's the card itself or the config of the drives that's causing the hangup.
OK. I can see the 80gb Hitachi as slave and it's set up in four partitions of 20gb apiece. The 6gb however, shows up as unnamed in Drive Set-Up and will not mount without initialization. I don't want to re-initialize it if at all possible because it has OSX on it and a bunch of other software that I was intending to use. I tried to mount with Norton 2.0, Hard Disk Toolkit, and SCSI Probe with no luck. Glad to have gotten this far, but like to see this disk without major surgery and/or labotomy. Thanks again. Scot.
If the 6GB was originally connected to the computer's internal ATA bus, it may require reformatting to use with the ATA PCI card, unfortunately.

Page 4 of the ATA/100 installation guide in PDF format confirms this ( I don't know if it applies to OS X, as I didn't have to reformat my drives when I moved them from the internal bus to the PCI ATA card, but my machine is newer and the drives I'm using are newer, so I can't say whether it's your computer imposing this or the card itself.
OK Thanks. I read that link and it's very helpful. I think I'll try a quick Norton fix to see if I can just mount it. The drive was on the main bus of the machine I took it from. I just don't want to lose all the apps and OS that's on it, if at all possible. Any "mount" utility suggestions appreciated. Scot.
Please don't say you're going to use Norton on that drive! Don't use ANYthing with a Symantec or Norton brand on it! Search on this forum and you'll see more problems than anything with Symantec/Norton stuff -- in addition, they've discontinued support for the Macintosh platform for Norton Utilities, and using outdated/discontinued software is a one-way ticket to problemsville.
"A quick Norton fix" might result in a lengthy process of pain. :D Norton doesn't play nice with Mac OS X, and hasn't been supported on Mac OS X by Symantec in a while. Try tools like Tech Tool Pro and others mentioned in the forums. Just do a search for "Norton" and you'll see what alternatives are available to you.