Startup Disk Suddenly Won't Boot?

Pierce Butler

To keep using certain legacy software, I've been running my iMac9,1 (mid-2009) computer from an external USB-2 hard drive under MacOSX 10.6.8 (Snow Leopard). All went well until recently, when the volume in question (and a backup on a separate drive) stopped working as a boot disk - it doesn't show up as an option in the Startup Disk System Prefs panel, nor when I hold down the option key on startup.

Fwiw, another SL partition on the same disk shows up in both cases and works just fine, and the problematic partition mounts, allows use of every file I've tried, and gets a clean bill of health from Disk Utility, Drive Genius, and TechTool Pro (latest versions of all three, though I haven't had time to try the full physical surface check test, which would probably take over 48 hours). It did show up as an possibility once when I did the option key/startup routine on a MacBook Pro, but the actual startup went to the internal HD on that MBP.

One important file I can't access, even through Migration Assistant: my Address Book data. I plan to switch everything I can to a MacOSX 10.11.6 (El Capitan) volume, but I don't know what to tell the Contacts app "Import..." command to go to on the SL drive (and can't get the Address book app there to do an export).

So - help! All comments and suggestions welcome...
This would be a good time to find your Snow Leopard installer DVD.
Boot up to that DVD, and reinstall Snow Leopard. This will do several things for you:
Assure that the installed system is on a bootable drive.
Re-do the various system files, making sure that all are complete, and in the proper location.
You will revert back to 10.6.3 (unless your copy of the installer is even older than 10.6.3), so you would then need to run software update to get your system back to the most current update. This process will NOT erase your drive, nor cause you to lose your important apps and files - unless you make the choice to erase the drive first
Running DVD-based installer on an existing boot drive doesn't erase the User folder and accounts?!?

Does this provide any advantages over installing Snow Leopard on a new volume, running the relevant updaters, and using Migration Assistant?
Running DVD-based installer on an existing boot drive doesn't erase the User folder and accounts?!?

Does this provide any advantages over installing Snow Leopard on a new volume, running the relevant updaters, and using Migration Assistant?
Correct... Installing OS X does not erase the User folder and accounts, unless you choose to erase the boot drive. The OP does have a backup, so erasing, and restoring everything can give a good result.
However, if the non-booting is pretty recent, then a little corruption somewhere in the boot partition might be all that is happening. Reinstalling OS X can be a fairly quick return to "normal" (a booting system)
A partial history about OS X installers: Snow Leopard changed to a setup similar to Lion and later, where erasing can be done while booted to the installer through the Disk Utility that is part of that installer. Earlier OS X versions (Leopard and older) had several install options. One was to erase the boot drive (losing everything that was not backed up), or an install without erasing, when the blank drive was already prepared. Or the OTHER option called "Archive and Install", which did an internal copy of the current system to a "Previous System" folder, and would maintain the current apps and network settings, etc. Snow Leopard and later did away with that option, where the normal OS X install is similar to the older archive and install, in that the existing setup, apps, files, and settings in the system are maintained in the standard reinstall.

What's the advantages with that method? Mostly the time involved is much less. You ALSO do run the risk of the reinstall where the issue is NOT fixed, maybe even not helped in any way.
But, I think it is a good step to try in this instance.
If the you finds that the quick reinstall does not help, then you go on to the full erase and restore from backup.
One disadvantage, at least with Snow Leopard. The most recent full install is for OS X 10.6.3 - as Apple never updated the commercial installer DVD to a newer system. So, the standard Apple apps mostly go back to some older versions. But, Software Update takes care of all that, at least for the Apple system updates. Your own apps would not be affected, other than waiting to launch a few apps that NEED the completely updated Snow Leopard to work properly. Again, if you do all the system updates then, that should not be an issue, either.

Thought I should also point out that a reinstall sometimes will bring out problems that are happening on the boot drive, where the problems begin because the drive is close to failing. The install might make that happen more quickly - when you get a failure of the install, maybe with errors reported, etc. And, then you consider stopping where you are, replacing the drive with new, and continuing with a full install on a new hard drive/SSD --- drives fail, be prepared for that possibility :cool:
After a bit to get my nerve up, I proceeded with the update-from-DVD process.

It worked as you said - almost.

The volume now boots and functions well, except that it no longer recognizes my password (even though it gives the same "hint" as before), and now wants me to enter a sysadmin name (and does not accept the name shown in the Systems Prefs/Users panel). Without that, I can't run the MacOSXUpdCombo10.6.8.dmg updater it took 2 hours to download, or even, say, correct the Time Zone prefs panel.

Still, I exported my Address Book data, and (apparently) successfully imported it into the Contacts book on my El Capitan volume, so I feel considerably less stress than before - thanks much for that!
Check in your Users & Groups pref pane (which shows the user accounts in the left side of that pane.)
Does your normal account show as an admin? Or is it listed as a Standard account (or something else?)
Do you have ANY admin accounts, that show up in that accounts list?

When you mentioned "sysadmin name", then maybe you have an unusual setup where you have the root user enabled (?)
If you log out, the login window would show you a choice for a user named "Other..."
You can also enable the root user while booted to your Snow Leopard installer, and going to the menu item "reset password".
Choose the system administrator account, and supply a password. Save, then restart your Mac, choosing the "Other" account, and entering the password that you just set up.
That will log you in to your root account - and you can THEN go in to the System Preferences, Users & groups pane. AND, now you can change your normal user account back to an admin account, AND you can change the password in that pane, so the account has the password that you want. Once you make sure your usual account is both an admin, and has the correct password - log out, then log back in to your usual user account (and the system should let you do that now!)
You should disable the root account, after you have your system back to normal.
Come back with your results, either success, or failure (be sure to give some details if that fails to help!)
Last edited:
I'll have to reboot from that external drive to try out your suggestions, and have some chores to finish first.

As for "sysadmin", I admit I was using the term casually, not precisely.

More later... (tonight, I hope)!
Well, didn't get to it until this morning.

Booting from the Snow Leopard volume, I saw an "Accounts" panel in System Prefs, which showed me the two "Standard" users I'd had there before.

The one I'd logged in as was the only one not grayed out; though the padlock icon was closed, I could and did try the "Change Password" button - but when I entered the same password I've used all along, I got the same message ("Enter admin name and password") I've gotten nowhere with for days. (Same thing happened when I clicked the padlock icon.)

Any other details I should've noticed?
Yes, there is one other little detail:
If you only have two users listed in the Accounts pane, and both are "standard" users - then you don't have any admin account.
That's the problem! If you don't have an admin account, then there is NO admin password that you can use. You really need at least one account to be an admin account, even if it is not the regular account that you use. There MUST be at least one account listed as an admin account...

This happens sometimes. It's just a one-time glitch in the system upgrade process, where the normal user account is changed from an admin account to a standard account.
Follow my steps in the post #6 to boot to your Snow Leopard DVD, and enable the root user account. (You CAN'T do this when booted to your system, because, without an admin account, you don't have a working password!) You MUST enable the root user while booted to your Snow Leopard installer.
Log in to that root account. You will then be able to change one of the standard user accounts to an admin account.
And, then log out of root user, and log back in to your usual account.
Let me know if you have more questions - or something that I mentioned does not work for you... (There are other ways to make one of the accounts an admin, but you have to enable the root user to do that.
I did as you said, everything worked, and now my SL volume is, I think, ready to resume life as a secondary boot volume while I continue adjusting to life under El Capitan.

One (hopefully minor) deviation: once rebooted as a (just-plain) Admin, I could see neither the System Administrator user account nor any way to disable same, so perhaps that remains lurking somewhere, ready to pounce when I least expect it.

Thanks mucho for rescuing me from the results of my own ignorance!
"System Administrator" appears in the Accounts pref pane only when you are logged in to the root user. If you are logged in as your usual user, then the accounts pane will not show the system admin, even if that account is enabled.
And, you will see an account simply called "Other..." when you have a login window. That's your root user account.
You can also check if the root user is enabled: In Snow Leopard, open your System Preferences/Accounts pane.
Unlock the pane. Click the Login Options button, then click on Network Account Server/Join button
On the resulting window, click Open Directory Utility.
Click the padlock to unlock the pane. Then, go to the Edit menu. You should see an item that says Disable Root User (which means your root account is enabled)
Click to disable the root user.
If it already says "Enable Root User", your root user is not enabled --- and you are done here.
Your system is essentially unlocked when the root user is enabled
The enabled root user allows you to do a lot of things in your system that would ordinarily require a password. (Admin password is not required after you are logged in to the root account)
Anyway, the usual recommendation is that the root user can be used when needed, but disable that account (so it is not available for others to use, or for remote use) when you are done with that task.
So - sort of a tools-left-lying-around situation. I don't know of anyone trying to poke into my system, but I agree with the idea of not leaving temptations open.

Thanks one more time for getting this problem straightened out!

(I should mention, just for the record, that when this non-booting problem first arose, it also struck my El Capitan (MacOSX 10.11.6) partition, but in that case I managed to fix it myself with a reset-Parameter-RAM restart.)