System Preferences Window Cutoff

nealt

Registered
When I open System Preferences its window opens in the upper left corner with the top half cut off. How can I fix this? No response from Apple Forum.


 

DeltaMac

Tech
Here's a couple of possible fixes:
Go to Displays (not visible, so SwitchResX should work), change your screen resolution to anything different, then change it back. That should bring back off-the-screen windows.
If that doesn't work, try the System Preferences menu, then change the sort (under the View menu in System Preferences (Organize by) to Categories or Alphabetical, etc. Change it back when the window is fully in view, if you like.
If neither of those work, then I would suggest going into your user folder, Library, then the Preferences folder. Delete the file com.apple.systempreferences.plist
Log out of your user, then log back in. Launch System Preferences. That should do it!
 

Cheryl

Rosie Moderator
Staff member
Mod
What OS are you running? Go to Apple Downloads and get the latest combo update. Quit all your apps before installing the combo, then see if that helps correct it.
 

DeltaMac

Tech
Are you running multiple displays?
Do you have another display that you sometimes plug in for additional screen space, but you might have unplugged it while you had the System Preferences open?
Plug that second display in, you may be able to move the pref window by moving the second display to an area above your main screen (in the Displays pane/Arrangement pane - which only appears when you have additional displays on your system) You may be able to move that pref window then.
Are you running Sierra?
Are you using SwitchResX to have a screen resolution that would not otherwise be available in the displays pref pane?
Try setting the resolution to another resolution, and see if that gives you access to the top of the window, so you can drag it down.

Turn off the top menubar, if you are running Sierra:
Click on the preferences window so you see the System Preferences menus at the top.
Even if the window is completely off the screen, you can use the View menu to get to any preference pane.
Choose General.
Turn off "Automatically Hide & show the menu bar"
Hiding the menubar may allow you to grab the top of the preferences window.

Come back if THAT doesn't work, there's other possibilities, such as booting to Safe mode.
 

nealt

Registered
I am running El Capitan. I do have 2 monitors.Changing the arrangement does not help. Since the top of the window is cutoff I can not move it.

One thing I noticed is that If, leaving the window open, I switch monitor resolutions the window is no longer cut off. If then I switch back to the native resolution, the window is no longer cut off. If I close the system preferences window and then reopen it the window is cut off at the top again.If I mirror the displays the window is no longer cut off.
 

jbarley

One more, for the road!
This is a stretch, but anything is worth a try.
Under the System Preference menu->View->Customize,
temporarily hide most of the lower pref panes and see if that might shrink the Preference window.
If it does then re-position the window and unhide the panes you hid previously.

edit:
something else to try,
select Displays from the View menu and rotate the screen 90 degrees, maybe you can catch the top edge this way.
 
Last edited:

nealt

Registered
If all I wanted to do was reposition the window I can use mission control. That restores the complete window.
 

DeltaMac

Tech
If all I wanted to do was reposition the window I can use mission control. ...
Ah, well isn't that what you are asking to do? (reposition the window/pull it down on the screen, so that the result is that it stays within the screen (?)
You could certainly try to do that by repositioning your 2nd screen so it is above your primary screen (again, in your Displays/Arrangements tab.)
You have to move the second screen so that it is positioned above your primary screen.
The top edge of the System Preferences window will be positioned near the bottom of that second screen, and you will be able to move it wherever you want.
If you did not try that (repositioning the screen so that it is above your primary screen, you need to try it.
It will help you. It will work.

Or, turn OFF most of your preference panes, which will draw down your over-sized preferences window so you can get it back under your control.
 

Cheryl

Rosie Moderator
Staff member
Mod
If all I wanted to do was reposition the window I can use mission control. That restores the complete window.
That is what I thought you needed as well - to reposition it so you can see the top part of the window. :oops:
 

nealt

Registered
Delta Mac's suggestion did not work. I do appreciate everyone's suggestions. Somewhere is stored the coordinates where System preferences initially opens. But where?
So let me explain: When I initially open sys pref it is positioned as shown above. If I close sys pref and reopen it the same thing happens. If I call up mission control while sys pref is open I can then position it anywhere. But this position is not remembered. Calling up sys pref again results in the same problem
 

DeltaMac

Tech
You have an abundance of junk (third-party) pref panes.
So, if you disable ALL panes that are not Apple, that doesn't enable you to move the pane far enough away from the top edge?
Try removing the preferences .plist file "com.apple.BezelServices.plist". It's not a .plist that would ordinarily affect the position of a window, but worth trying, I think. There's two of those, one in your user/Library/Preferences, and one in /Library/Preferences folder.
As is usual - restart after removing .plist files.
 

nealt

Registered
I removed all non Apple panes and all "com.apple.BezelServices.plist" files. Problem persists.

Another piece of the puzzle. If I minimize the sys pref window and then reopen it by clicking in the dock icon, the window opens normally.
 

Cheryl

Rosie Moderator
Staff member
Mod
Another piece of the puzzle. If I minimize the sys pref window and then reopen it by clicking in the dock icon, the window opens normally.
While that is not what you wanted as a solution, it is a good work around.

Have you tried disconnecting the second monitor?
 

nealt

Registered
Disconnecting t second monitor did not help.

I found out that I change the display resolution from the native resolution to a lower resolution the problem goes away even if I return to the native resolution. However quiting and then reopening brings back the problem.
 

nealt

Registered
"Go to Displays (not visible, so SwitchResX should work), change your screen resolution to anything different, then change it back. That should bring back off-the-screen windows."

This works until you quit sys pref and reopen it.
 
Top