[Tiger 10.4.11] Automator Pops Up When Trying To Open Fetch

LadySheba

Registered
I was working on a document in TextWrangler (3.1), saved the document, then opened Fetch (4.0.2) from the dock. Automator opens instead, and I don't use Automator!

I'm running Tiger 10.4.11 on a 400MHz G3 iMac indigo.
 

DeltaMac

Tech
Right-click on that dock icon for Fetch, and choose Show in Finder.
You should see the Fetch application. Drag your existing fetch icon out of your dock.
Drag the actual Fetch app into the dock, and drop it where you like.

If, instead, the Dock Fetch icon is actually for Automator (which also sometimes happens), then find your Fetch app, wherever it is, and drag that to the dock to replace your existing icon.

That will create a new dock icon for Fetch - dock icons occasionally don't "point" to the correct app.
That should take care of your issue.
 

LadySheba

Registered
I did that, and the dock won't accept the new icon. I can put it next to the Trash icon, though. Clicking on the new icon still bring up Automator.
 

DeltaMac

Tech
You have to drag the actual app. Sounds like you simply moved a folder that has your fetch app inside. Click that "icon", which should be still in its original location (your Applications folder is most likely), one click to select it, then choose Get Info from the File menu (or just press command-I). What is listed next to Kind? Should be Application, and NOT folder. What do you see?
If it says "Folder", then double click that folder, and find the Fetch application which you should find inside that folder. Drag THAT to your dock.

If none of that really works, then it seems possible that something has corrupted the Fetch application package. You can download another here: http://fetchsoftworks.com/fetch/download/
Drag your existing Fetch app to the trash, and put the new one in your Applications folder.
 

LadySheba

Registered
I did a new install, the dock still doesn't like the icon. Looks like I need to try something different.

And suggestions for a good FTP client?
 

DeltaMac

Tech
If you can't place the Fetch app anywhere else in the Dock, except at the end near the trash, then it's not an application, and I need to know what you see. That's why i asked about what that shows in Get Info, after you select Fetch.

Does anything change (can you do what you need to do with the dock?) if you restart your Mac?

Another different tip that may help is to download and install your combined OS X updater. Here's the download page for the correct 10.4.11 combined updater. http://support.apple.com/kb/DL170
I suggest that you be sure that you have a fresh restart before you install that updater, as it will "touch" a large part of your system as part of its job.

ftp client?
(not necessarily in this order...)
Fetch (you already know about that.)
Transmit (you need version 3 to use on 10.4 http://panic.com/museum/transmit/older/ )
Cyberduck (free!) (doesn't support 10.4, but you can download vers 3.2.1, which DOES support 10.4) http://trac.cyberduck.ch/wiki/help/en/faq

or google for Mac ftp clients for OS X 10.4

Suggestion - before trying a different client, do 2 steps. Download and install the 10.4.11 combined updater, which I already mentioned. After that all completes, open /Applications/Utilities. Run Disk Utilities. Select your hard drive, and click the Repair Disk Permissions button. That permissions repair on 10.4 only takes a few minutes. Next step - restart.
Then - try your Fetch. Don't use the Dock this time for that, but go straight to the Fetch app, see if that opens successfully for you now...
 

LadySheba

Registered
I checked the Get Info window, and the kind is "Application". Restarted the computer and the dock still won't take it.
 

LadySheba

Registered
Installed the updater. Tried to start Fetch without trying to put it in the dock; it won't open at all now.
 

DeltaMac

Tech
Check in your Console, to look for relevant info. The System.log is listed by time and date, so you can try to launch Fetch, and see if any messages appear in the log at approximately that time. you can post those here, if you like, and someone may be able to interpret what you see.

Did you Repair Permissions (with Disk Utility?) This might be one of those rare situations where that might help (and certainly won't hurt.)
 

DeltaMac

Tech
If you attempt to open an app, and nothing at all happens, then your system should report _something_ in the logs. You can also check to see if there is a specific log, just for Fetch.
 

LadySheba

Registered
Console.log does say "The file does not appear to contain a valid Automator workflow." But I'm not using Automator for anything. And Fetch is not a file, it's an application.
 
Top