Tiger upgrade / LaCie D2 problem


Hi, I've searched on this and tried all the possible fixes I could find but to no avail. Since upgrading to Tiger my Lacie D2 120GB won't mount and in fact freezes the finder (well, I get a spinning beachball of death and nothing will work).

So far I've tried...
  • Software update to 10.4.1
  • Combo update to 10.4.1
  • Resetting the firewire ports by powering off and removing the Powerbook battery for 20 minutes
  • Resetting the D2 by removing the power for 20 minutes
  • Removing and reinstalling the firewire extensions in /System/Library/Extensions

My iPod still mounts happily, but the D2 just isn't having it. Anyone have any other ideas?


U.S.D.A. Prime
There have been reports of faulty power supplies with certain LaCie d2 enclosures... you might wanna give LaCie a call and see if those symptoms are similar to the faulty power supply symptoms.

Common symptoms are sporadic mounting, errors when copying, disk freezing and inability to "see" the drive.

Also: you do disconnect the LaCie drives when updating your system, right? You should always disconnect all FireWire peripherals when either installing Mac OS X or performing an update to the system (like 10.4.1). Symptoms of FireWire drives left connected during a system update are similar to those described above.


It's not the powersupply, the drive is still fine on non tiger Macs. And of course, yes I disconnected all the firewire stuff when doing the upgrade.