Travel with Airport Express



This is my first post. I have been using my airport express with my ibook (with OS 10.3.9) for a while now in the US. Currently, I am on a trip to India with both computer and AE. However, I am not able to get AE to work. When I plug it in, the green light flashes once for a second and then there is no further response. The manual says it is supposed to blink yellow/amber till it starts up. This is not happening.

I tried resetting by pressing the reset button for 10 seconds. This has not helped either.

I assume that AE works on 220V as its specifications say that it works on a variable voltage from 110-240V.

Could anyone please help me troubleshoot and fix this problem?


You may have already done this, but you didn't mention it, so I'll post it.

It's so obvious that it's easy to overlook - but did you setup a new AE profile at the location in India? AE was previously working at home, with a specific network profile. That profile won't be the same on your travels. So each time you set it up in a new place, it'll need a new profile or configuration.

Run the Airport Setup Assistant.

Hope that helps.
vinsea - were you able to resolve your problem? I have an airport express that it having the exact same symptoms: led blinks once after plugging in, then nothing. it was working fine until i unplugged it and tossed it into my suitcase. after arriving at my in-laws (no wireless!) I plugged it in and noticed this behavior. tried hard reset, plugging into UPS, but nothing works. any assistance would be greatly appreciated.