Twainbridge Crash

davidramsay

Registered
I have a Canon 3200F scanner, the syslogs show constant crashes of TWAINBridge.

Anyone got any IDea? (I have a snapshot of one of the most recent)

Daver

PS When the scanner isn't connected then crashes stop
 

vanfruniken

Registered
Scanner: Canon 3200F
MacOS X 10.2.4 on iMac G4 @ 1.25 GHz, w. 768MB RAM
In the system log I see
Sep 6 12:37:52 iMac17-FV crashdump[526]: TWAINBridge crashed
Sep 6 12:37:53 iMac17-FV crashdump[526]: crash report written to: /Users/franklin/Library/Logs/CrashReporter/TWAINBridge.crash.log
every 10 secs or so, until I unplug the USB cable to the scanner.
There is also a crashdump, but I am not really able to analyse crashdumps.
 

davidramsay

Registered
Good to know I am not the only one. As soon as I disconnect USB then the crash stops.

I am on 10.4.2 so there is no hope for you that an OS upgrade will solve. The problem has to lie with the TWAINBridge software and I do not know if that is Canon or Apple.

I do know that there hasn't been any fixes posted by Canon.

Regards
 

diddou

Registered
with scanners canon 3200F on mac osX

I had excactly the same problem described above until I plugged the USB directly on the G5 instead of the hub on screen . works perfectly now with scangear . I've read that a powered hub would be ok too .
hope it will help
 

diddou

Registered
I found the tip yesterday reading somewhere and it works for sure now for me ; tried on a powered hub and it works too with vuescan and twain import from ps. did you tried a reinstall of scangear with the last version available on canon website ? Sorry that i can't help you for the moment but if I find something I let you know
G5 1,8x2 on 10.4.2
 

davidramsay

Registered
Thanks, I find at the moment it is eaier to keep the Scanner unplugged unless I need to use it. I have re-installed the relevant software and unless it has changed recently then I am unlikley to find another re-install a success.

Daver
 

subsolana

Registered
i just ran across the same problem, since the 10.4.3 update. i've been having mysterious freezes, and my computer has been running a little slow since the update, and i opened activity monitor and noticed that crashdump rises to the top of the list about every 5 seconds, taking %99+ cpu. opening the system crash log, i noticed the twainbridge crash.

so, i went to system/library/image capture/devices, and control clicked the twainbridge file and moved it to trash (i tried to just drag it out onto the desktop, but it copied the file instead of moving it, because it's locked; so when you move it to the trash, you have to enter a password, and from the trash i moved it to the desktop so i can keep it if i need it later). scanning still works using canon's canoscan toolbox software (i just push the scan button on the front of the 3200f). hope this helps.
 
Top