USB Flash Drive Cant be formatted.

scat95

Registered
Hello everyone. I have USB3 Flash Drive. I have been using it for 3-5 months and one day suddenly it needs to be formatted.However when I try to do so on Windows machine, it says that it is read-only. When I use Disc Utility on Mac all options, except "Verify Disk" for the flash drive is not availible.
When I press Verify Disk in First Aid, the next log is given:
Verifying volume “SCAT”
Checking file system
Journal need to be replayed but volume is read-only
Checking Journaled HFS Plus volume.
Checking extents overflow file.
Checking catalog file.
Checking multi-linked files.
Checking catalog hierarchy.
Checking extended attributes file.
Checking volume bitmap.
Checking volume information.
The volume SCAT was found corrupt and needs to be repaired.
Error: This disk needs to be repaired. Click Repair Disk.

However,as I said, all the options, except "Verify Disk" are not available.
I tried a few software on windows which are supposed to format it. I tried to delete partition, but anything in vain.

Can anyone help me out here?
I am using MacBook Pro 17'' 2006 Model.
Thank you.
 
Last edited:

midijeep

Registered
From my experience it is history. I had the same problem and never got it resolved. Hopefully, you have back up files.
 

DeltaMac

Tech
I agree - if you can't format it on either a Mac, or a PC, then it's not likely recoverable (or trustworthy :D )
 
Top