using foomatic/ ppd printer "drivers"

HI, I am trying to use my existing laser printer on my new Mac, running 11.2.1.

Printer is Dell 3010cn, I'v e used it in the past on older versions of Mac OS X using Ghostscript / CUPS / Foomatic RIP and a Foomatic ppd file. Network printing not local USB.

It looks like foomatic-RIP pkg hasn't been updated since 10.8 or so. I looked to see if it was now incorporated by default but it doesn't look that way.
The most recent Foomatic-RIP pkg available (source is below) won't install.

I put on Brew, used Brew to install ghostscript-9.53.3_1.big_sur.bottle.tar.gz.
I pulled my ppd from the open printing location (below) and placed it in: /Library/Printers/PPDs/Contents/Resources
When I'm adding a new IP print, via LPR, I can chose this printer, and the OS X printer setup can see the printers IP. I am able to query it for supply levels and they look right.

However attempting to print anything I get an error that the printer is not installed correctly.

The fact that foomatic-RIP hasn't been updated since 10.8 makes me think something else is available for RIP printing and I am not finding it.
I have the working Foomatic PPD so it should be possible to use that information and make a ppd that works with another solution.

Am I missing something that makes this easier and I just need to find it?
Or has something changed and I could be quite stuck with support for this printer under modern OS X versions?

Thank you for thoughts- I have a post pending approval for a while now that has links to the software and how-to's that worked in other versions of OS X, but that post doesn't seem to be getting released.

Brian.
 

DeltaMac

Tech
Have you tried Gutenprint? Your specific Dell 3010cn is not listed, but maybe the Gutenprint drivers will provide a solution as a generic printer.

Is your new Mac an M1 model? That may be more challenging, as there seems to be more reports with printing problems with the M1.
 
Top