Windows filesharing

mala

Registered
Hi,

try to map a nework drive from Win XP to my iMac running Panther. I turned on "Windows Filesharing" in OS X and the "Map Network Drive" from XP but all I get is "The network path \\myimac\myshare could not be found" all the time. Tried FTP as well but that failed too. Ping works between the two and I also tried to turn of the OS X firewall. What have I missed?

TIA

Mala
 

SubaruWRC

Registered
Since I come from a Unix and Windows background, this was an easy solution when I ran into the same situation, and is common amongst all Unix variants including OS X. Unfortunately, Apple still makes SMB/CIFS extremely difficult to use, and there is no good reason for this. Have you tried sharing a printer via SMB/CIFS yet? Have fun. Again, Apple is making it for more difficult than it needs to be. Hopefully, they will fix this in the future. Or someone will make a utility to do it for them.


To answer your question, you need to type the following:

smb:\\server\sharename

if you have it password protected, you can type in the following:

smb:\\username:password@server\sharename
 

mala

Registered
Hi,

tried this with no luck...the instructions that becomes visible when I highlight Windows Sharing says "Windows users can connect to your computer at \\server\sharename" without the smb: prefix.

Any other ideas? Thanks.....

/Mala
 

ElDiabloConCaca

U.S.D.A. Prime
Try forward slashes instead of backslashes, and also try connecting with the IP address of the machine instead of the machine name.

Like this:
smb://192.168.x.x./share
 

mala

Registered
I've used the IP address all the way to eliminate one cause of problem and the use of forward slashes didn't work either I'm afraid.
As ping works is there any way of testing that the right port (139, SMB) also works?

/Mala
 

ElDiabloConCaca

U.S.D.A. Prime
Can you describe your setup in a little more detail? How is your network set up, and what devices are connected to the network, including hubs/switches/routers? Any firewall?

Got any operating system haxies or anything like that, like Little Snitch or something? Have you checked the OS X firewall settings in the "Sharing" pane of the System Preferences to make sure that the correct ports are open?
 

jh2112

Registered
try setting up a new user on the xp machine, specifically for this purpose.
I don't know why but it worked for me.
(I had tried just about everything!)
 

mala

Registered
It turned out there was a firewall installed on the XP box that prevented access to the LAN where the Mac resides. I fixed the firewall settings to allow traffic on this LAN and now it works fine. Thanks for Your help!

/Mala
 
Top