Wired Internet Speed Is Slow

jodypla

Registered
Hi, I pay for 200mbps with TWC and I have a Netgear CM500 High Speed modem and when I do the speed test, I am only getting 60-70Mbps. I spent an hour on the phone with TWC only for them to tell me it is an Apple problem. Is this true? Does anyone else have this problem? I'm on the iMac using OS X
Thanks!!!
 

SGilbert

Registered
Your speed is as fast as it's weakest link. Does your Netgear have 5Gig? It will be faster than 2.4 (and less likely to have interference). Have you tried ethernet to the router? It will be even faster.
BTW: 60-70Mbps is quite fast. I pay for 50 with Comcast and get 60-70 consistently on 5G--80's thru ethernet.
 

jodypla

Registered
Hi, Thanks, I am not sure if it has 5Gig, it just says high speed cable modem up to 680mbps. I do have it connected to the ethernet directly from the router. I am paying for 200mbps, so I am wondering if I downgrade to 100 or 50, will I still get at least 50mbps?
 

SGilbert

Registered
Theoretically, you'll never attain the total rated speed. If you can get 75-80% of it, you'll be doing great.
If you go 100, you'll average 75-80; if 50, you'll average 35-40.

If it were me, I'd downgrade to 100.

I forgot: your processor also has a relation as to speed.
 

Satcomer

In Geostationary Orbit
Hi, I pay for 200mbps with TWC and I have a Netgear CM500 High Speed modem and when I do the speed test, I am only getting 60-70Mbps. I spent an hour on the phone with TWC only for them to tell me it is an Apple problem. Is this true? Does anyone else have this problem? I'm on the iMac using OS X
Thanks!!!
To see what a OS X Mac is receiving it's wireless just hold down the option key+click on the Finder Wi-Fi icon. This way you can tell what wireless speed you are getting.

Besides the manufacture doesn't even advertise the Ethernet port speed! If if we're me I would look at X other modern modem with a 100/1000/1000 port on it!
 
Last edited:
Top