Bluetooth / Sharing


When I try to browse the public folder / drop box on my iMac from my MBP, I get a message that I don't have permission.

On my iMac I right click on the public folder in the sharing pane, I get this message:

View attachment 8357

I'm not sure what this means?


U.S.D.A. Prime
It means that, not only do you want to apply any changes to the drive itself, but do you also want to potentially change permissions on items that already exist on the drive, and all sub-files and sub-folders as well.

In other words, let's say you had a drive with a folder on it that "Bob" owned, and permissions were set on that folder so that only Bob could read/write to it.

Then "Dave" wants to access that drive as well. So, you change the sharing permissions on the drive to allow Dave, and you are presented with that dialog, which states, "Do you also want to change Bob's folder to allow Dave access as well?"

Whether you hit "ok" or "cancel" depends on the scenario above. In other words, do you want to change the permissions for only NEW items created on the drive, or all EXISTING items as well?


Thanks for the details.

When I tried bluetooth browsing again, it worked, with no apparent changes on my part.

In this case, there is only the one folder. So, the message all enclosed items is not clear to me.

Also, if I hit ok, is this reversible?


Your Public/Shared folder may be just one folder - but the "enclosed items" are everything inside that public folder. If the file ownership/permissions of that folder are incorrectly set, that can include all the enclosed items inside that folder.

I expect you restarted sometime during your latest tries - and a full restart can sometimes make some odd problems disappear.
Will the fix be permanent? Only you will know the answer to that one...