Cannon Scanner And El Capitan Security Update 002 2018

nealt

Registered
Canon 9000F scanner with the latest drivers.Using the Canon scanner app.
When I do a preview I can no longer select an area to scan. The driver also crashes randomly.
I tried safe mode and a new account with the same result. Canon and Apple had no suggestions.

Any one else have this problem? Anyone know of any solutions?
 

DeltaMac

Tech
The download site that riska anisa links is for a third-party download site (not Canon - other than the web page name) which does not offer the latest software.
For example, that site offers version 16.1.0a, nearly a year after Canon official site shows the current version as 16.1.0b (the minor difference in version number might actually be important to the user)

As is often seen, it's one of the sites that offer updates for lots of different manufacturers, and one of those sites that make you remember that you should always try the real manufacturer's support first.
One should always be cautious when downloading driver software from sites that are not controlled by the manufacturer.
 

nealt

Registered
I had the same problem same hardware. Get the latest Apple security update 003 or 004. That fixed the problem for me.
 

inkdriver

Registered
I have tried downloading the latest version of canon 9000f on this website and there is also another version.
inkdriver.com
they give us easy navigation and experience for users.
 

DeltaMac

Tech
Looked at that inkdriver site. Yes, some are Windows only, but other printers show downloads that appear to be correct for macOS.
But, the site is very poorly designed. Looks good, until you actually try searching for individual printers - and the Canon category is completely useless, brings up Epson, not Canon :rolleyes:. This thread is about Canon 9000F drivers, which are not even available on that site.

Don't you just love posters who are essentially pushing their own site? (and the site is incomplete, too!)
@Cheryl - did you disable the weblink on that post? It was showing as a valid link a couple of hours ago, and now is just text
 
Top