caps lock turns on num lock on macbook pro

MX5Bob

Registered
MacBook Pro 3,1, 2.4ghz, OS 10.8

When I hit the caps lock key, the num lock turns on and nothing shuts it off except a reboot. Any suggestions?
 

Satcomer

In Geostationary Orbit
Do this. Open System Preferences->Language & Text, Input Sources mini-tab. Then put a checkmark the small box for 'Keyboard & Character Viewer'. Then scroll down to your countries flag and put a checkmark in that box. Lastly at the bottom of the Language & Text pane put a checkmark in the box for 'show Input menu in menu bar'.

Now you have your country's flag in your Finder bar. So click on the flag and select 'Show Keyboard Viewer' and now you will be able to see every key you press. This can help sometimes in trouble shooting strange keyboard issues.

Lastly click on your desktop. Then when, in the Finder menu bar, the word 'Finder' appears and hold own your 'option/alt' key while clicking the Finder menu item. In the drop-down select 'Library'. When the your Library opens up go to the folder "Preferences'. In 'the Preferences folder select the file com.apple.finder.plist and move it to your Trash can, but don't delete it yet. Then reboot and see if the same problem appears. Good luck.
 

DeltaMac

Tech
You won't find the "Library" item in the Finder menu. "Library" will appear under the "Go" menu in the finder menubar while holding your Option key.
 
Top