CD Burner seems to not work anymore HELP


My MATSHITA DVD-R UJ-845E: on my Powerbook. I insert a CD nothing happens, get a weird noise and ejects. Can someone help me please!


In Geostationary Orbit
how old is the Powerbook? Have you ever cleaned it sing compressed air or a Cd/DVD cleaning disk?

I ask these questions because with the noise it sounds as if that drive might be gone.


Yet another Matshita failure? If after having tried Satcomer's suggestion, and the problem persists, then get that drive out of there and replace it with a Pioneer.


My Matshita DVD-R UJ-845E does the exact same thing as you describe, so I purchased a Pioneer DVD-RW DVR-K16M, and it does the same thing as the Matshita!! I can get iTunes and System Profiler to recognize the Pioneer same as the Matshita, but Disk Utility does not see either burner...should Disk Utility show/see the either burner, because I thought it used to?...? I tried PMU Reset...I tried clean caches...I tried holding trackpad while restarting for the heck of it...I restarted in safe mode and did something... I'm starting to think some application like toast or something, which i downloaded once, tried to use, and deleted, has done something to my something somehow. Or maybe something totally different... HELP. I just wanna burn again either with this pioneer or my internal matshita.

Powerbook g4 17" 1.67 GHz PowerPC Mac OS X 10.4.11
512 MB RAM


Registered Bot
I've had MATSHITA drives fail in both my MacBook Pro machines. I also had burners fail in my iMac G4 and my Power Mac G5. These things don't seem to be very reliable, in my limited experience.

LuriceO: In your case, since you're having the same trouble even after you replaced the drive, it probably wouldn't hurt to reinstall the operating system (OS X). You'll have to back up your important data first, everything in your home folder. Then put in your system disc, reboot while holding down C on the keyboard. Select the Options button near the bottom of the screen and select "Archive and Install" if you can find it.

In any case, reinstall OSX 10.4, then you'll need to update it to 10.4.11. After that, try your new Pioneer burner. (It may be, though, that the new burner is defective.)

Good luck and let us know how it goes.

P.S. Be careful about buying used replacement burners. I bought one from Hong Kong and it was defective. Found out after I tore open my old-style MacBook Pro to install it. Not cool.


i will re install eventually i guess. I need external hard drive first i guess.

I was hoping someone would know what application I may have downloaded that may have confused my mac somehow. Like an app that made a .plist file or something? Because after I re install os x, I will likely redownload the same app or whatever that is causing this problem and end up back here where i started.. you have any suggestions as to what apps could somehow mess with your superdrive?

Thanks for your reply


In OS X 10.4.11 and older, the CD/DVD burner may not appear in Disk Utility, unless you have a disk in the drive.


OK it's been almost a whole year but I have finally updated my OS from Tiger to Leopard 10.5.8 on my old Powerbook G4. I did a clean erase and install after learning myself how to partition an external hard drive and after learning how to back up my data using the freeware named carbon copy cloner.
All software is up to date, and as of now, the internal main hard drive has only the apps that come with Leopard on it.
Both iTunes, Disk Utility and System Profiler all display my internal Matshita drive. My old Pioneer disk drive, however, is only displayed by iTunes in the final window you see before you are asked to put in a disc for a burn. It is in the drop down menu where I can choose between my Matshita or the Pioneer. Unfortunately, both fail, doing the same thing they did when I was using Tiger.
Do I have a bad Pioneer drive, too? The strange thing is that both drives do the same things, except the Pioneer doesn't spit the disc out like the Matshita does. The Matshita is a slide in slot, and the Pioneer has an eject tray. The Pioneer just keeps spinning the disc in the same buzz-whirr noise pattern as the Matshita.
Now I'm looking into a LaCie disc drive, and ways to make the Pioneer display in disk utility and/or System Profiler, to see if that will help. Also, In System Profiler, would it show up under Hardware>Disc Burning OR Hardware>USB, since i have it hooked up through USB? Thanks in advance.


im also looking into buying a new matshita drive and installing it myself... I did finally get my external pioneer drive to show up in Disk Utility, but it still did not work.

I just want to be clear, my matshita cd dvd drive in my powerbook g4 ejects disks automatically after a minute. I've tried everything including getting a new drive and doing a clean install (erase and installed OS X 10.5.8). What should my next step be?


lurice0 - when you have your external Pioneer drive connected, and insert a CD or DVD into that drive, does the disk mount on the desktop, or can you see the disk in a finder window?
When you say it "still did not work", that would mean that it doesn't recognize a disk.
Do you mean it won't boot to an OS X installer DVD?
Is your external Pioneer drive using a FireWire connection, or USB?

If the Pioneer drive doesn't work - how did you install OS X?


Thanks for replying DeltaMac-
I re installed os x by recommendation of ex2bot in this exact same thread! It took me like a year to figure out how. I had to get a big external hard drive and partition it, which means to divide it up into sections, which is done through Applications>Utilities>Disk Utility. I made mine into three sections, and you can pick any size you want the sections to be, so I made a small section for my install disc images. Then make your intall discs into .dmg's or whatever type files somewhere else and then put them onto the external hard drive. Then go to System Preferences>StartUp Disk and select the partitioned section of your external hard drive that you put the os x installer on and restart your computer, basically.

My Pioneer is Not Firewire, it is USB and is from eBay, so, it could be defective, I was stupid to buy it, but it was cheap, and I thought it would at least diagnose the problem, ya know. When I put a disc in, it does not mount on the desktop, or the finder window, or disk utility. Although, the computer does recognize the Pioneer itself. However, when a disc is inserted into the Pioneer it just buzz's and whir's and then eventually after a considerable amount of time i give up and eject the disc. The Pioneer may not be defective because the built in Matshita does the same thing. If I insert a disc into the Matshita, it just buzzs and whirs and spits it out automatically because its a slot loader, not a tray loader like the Pioneer. And neither one mounts anything anywhere.

Also, the mac only recognizes the burner every once in a while and when it does, i can only get hardware information on it, but i dont think i see it in disk utility. I know I just need to upgrade to a new computer but this G4 is still running so I'd like to keep it at 110%

Thanks for any help