External HD Error message but no problem on check.

sgould

Registered
When I start-up my computer in the morning, I'm getting a message that says

"Mac OSX was unable to repair the disc "G-Tech 4b". You can read and copy files from this disc but you cannot modify or add files. Backup and reformat disc as soon as possible".

G-Tech 4b is one of the two partitions on a 4TB G-Tech external hard disc. It has just some copies of files on it. The other partition "G-Tech 4a" holds a full clone (Superduper) of my iMac.

I ran Disk Utility Repair on both partitions and the whole disc. The result in all cases was "This disc seems to be OK".

When I look at the list of available discs in the sidebar of the main HD window "G-Tech 4b" is listed, it is greyed out but still selectable....

Any ideas of solving this?

A reformat will surely only be on the who;e 4TB? Which will wipe out the clone and the incremental updates.

Main machine is iMac 27 inch 2010. The one with the new display. Running 10.7.5. Connections are USB.
 

Satcomer

In Geostationary Orbit
How do you have formatted? Plus how long have you had this drive and is the USB 3 version or the older one with Firewire 800?
 

sgould

Registered
I've had the drive 8 weeks. It's the USB connection. The disc will do USB3. My iMac does USB2 (mid-2010 model - bought Dec 2010).
 

Satcomer

In Geostationary Orbit
Again I ask how is formatted?!

IF you have formatted HFS+ then with a little Terminal trickery you could use FSCK -yf on it and I can show you how if for give me the name of the hard drive or you could buy something like DiskWarrior or Dive Genius.

Lastly have you tried a different USB cable or performed a Reset Your PRAM on it?
 

sgould

Registered
Ooops! Yes it's HFS+ format.

Last time I reset PRAM was on the iMac just after I bought the HD when the display failed. How does PRAM reset affect an external disc? I thought it only reset the iMac.

Had another look with Disk Utility. The option is there to Verify both partitions, but the Repair button is grey on the partition that has failed.

I could try some terminal stuff. Never risked it before!!

The actual partitions are

G-Drive-4.1
G-Drive-4.2
 

Satcomer

In Geostationary Orbit
Ok I will list some /Applications/Utilities/Terminal steps to 1)get the Name of your hard drive, 2)run the Unix fsck -yf on that external.

1)Get to the directory that list the names of your connected drives

Code:
cd /Volumes/
2. Remember the name of your Hard Drive

Code:
ls-la
3. Get into you drive via Terminal

Code:
 cd /Volumes/Name Of YourHardDrive/

4. Run  the Unix fsck -yf on it by this command (you prompt should say wait directory you are (make sure it is the external hard drive)

[code]sudo fsck -yf
Let that run until you get another Terminal prompt. Pay attention to the readout. If it can't repair the drive then some hardware issue might be wrong with it and/or you can get one of those commercial/sharewares to try to repair it and consider getting another brand of hard drive and pay attention to drive installed it it. IMHO Western Digital drives fail miserably to frequently high in OS X.
 

sgould

Registered
I'm doing something wrong. I can't get Terminal to work like that....

But I have to make some corrections to the info I gave. Another Oooops!! Apologies.

G-Drive-4.1 is a 2TB partition on the 4TB G-Drive HD. It is formatted HFS+

G-Drive-4.2 is the other partition, also 2TB, but it is formatted as Journaled HFS+

And the mistake is that the connection is not USB but Firewire 800. I don't have a spare cable to try, but it's only one partition on that drive that isn't working. It has got itself listed on the System info as non-writable.

From the system report on my iMac.

G-DRIVE:

Manufacturer: HGST
Model: 0x3550
GUID: 0x1C********* (ID erased by sgould)
Maximum Speed: Up to 800 Mb/sec
Connection Speed: Up to 800 Mb/sec
Sub-units:
G-DRIVE Unit:
Unit Software Version: 0x10483
Unit Spec ID: 0x609E
Firmware Revision: 0x110
Product Revision Level:
Sub-units:
G-DRIVE SBP-LUN:
Capacity: 4 TB (4,000,787,030,016 bytes)
Removable Media: Yes
BSD Name: disk1
Partition Map Type: GPT (GUID Partition Table)
S.M.A.R.T. status: Not Supported
Volumes:
disk1s1:
Capacity: 209.7 MB (209,715,200 bytes)
BSD Name: disk1s1
Content: EFI
G-Drive-4.1:
Capacity: 2 TB (2,000,393,515,008 bytes)
Available: 1.7 TB (1,699,247,783,936 bytes)
Writable: No
File System: HFS+
BSD Name: disk1s2
Mount Point: /Volumes/G-Drive-4.1
Content: Apple_HFS
G-Drive-4.2:
Capacity: 2 TB (1,999,915,323,392 bytes)
Available: 1.94 TB (1,936,964,734,976 bytes)
Writable: Yes
File System: Journaled HFS+
BSD Name: disk1s3
Mount Point: /Volumes/G-Drive-4.2
Content: Apple_HFS
 

sgould

Registered
I have just tried the "Get Info" window. And all permissions are greyed out and don't change when the lock is unlocked.
 

sgould

Registered
The Verify list from Disk Utility has a comment in the last line about "ACL". Is this anything odd?


Verifying permissions for “G-Drive-4.1”
Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent” has been modified and will not be repaired.
Permissions differ on “System/Library/CoreServices/Menu Extras/Displays.menu”; should be drwxr-xr-x ; they are lrwxr-xr-x .
Permissions differ on “System/Library/MonitorPanels/Arrange.monitorPanel”; should be drwxr-xr-x ; they are lrwxr-xr-x .
Permissions differ on “System/Library/MonitorPanels/Display.monitorPanel”; should be drwxr-xr-x ; they are lrwxr-xr-x .
Permissions differ on “System/Library/MonitorPanels/Profile.monitorPanel”; should be drwxr-xr-x ; they are lrwxr-xr-x .
Permissions differ on “System/Library/PreferencePanes/Displays.prefPane”; should be drwxr-xr-x ; they are lrwxr-xr-x .
ACL found but not expected on “private/var/db/launchd.db/com.apple.launchd”

Permissions verification complete
 

sgould

Registered
I copied all the files from the bad disc, reformatted the disc and copied it all back. It seems to be OK now. But I will keep an eye on it.
 

sgould

Registered
Yes. It's always a worry when odd failures happen. But it's not my Time Machine. That's on a 2TB G-Drive (!!) and I've had it for 18 months with no problem.
 

sgould

Registered
Would there have been a problem with the two partitions being different formats? One HFS+ and one Journaled HFS+ ?

I thought I had them all as Journaled to match the iMac. Could it have changed itself? Probably not as I could copy all the files off.

Is there any app that can give the disc a really hard "workout" to see if it breaks?
 

DeltaMac

Tech
Your Disk Utility will work your disk pretty hard - if you want to erase it!

Disk Utility/Erase/choose Security Options...
Set for a single pass of zeroes. Start the erase, and it will write zeroes to every block on the drive. 4TB will take a considerable length of time (several hours) If you decide to do multiple passes (up to 7), then you can wait a couple of days... Not recommended by most users (it's too hard on the drive) but is apparently acceptable for secure erasing at a government level.
single pass would be enough to show problems, if the drive is on the edge.
If you want to do that, I suggest that you erase/zero the entire drive, and not just one volume.
Any of that takes a long time - and, of course, you lose anything that isn't backed up somewhere else.
 

Satcomer

In Geostationary Orbit
I had this happen on my 2008 Dual Mac Pro's main internal drive. Thankfully I ordered a 2TB replacement and was able to clone back to the new internal main drive (thanks CCC).

I can't urge people hard enough to ALWAYS have a ready available current backup! Schedule the backup to happen regularly and keep up on it since you never know when your main hard drive gives up the ghost.
 
Top