Folders Turned Into Unix Files After Ejected During File Transfer

Fiddlestix

Registered
Hi,

I've searched through similar threads but can't find a solution for my situation.

I'm using OSX 10.11.2 and I had been using a USB card reader to transfer files from an SD card (used in my GoPro) to a hard drive FAT 32 formatted.

The card reader was ejected by mistake midway through transfer and when I put it back in the folder which I had been transferring files from has now changed to a Unix Executable file and says it has 0 bytes.

I have tried to unhide the files and there are no hidden folders or files shown that have my files. I'm stumped and I really hope that the files are somewhere.

Can anyone help here?

Further Info:

I put the card back in the GoPro and took a picture and that created a new folder. Also all other folders apart from the one that was being transferred are visible and have all the files in them.

(Using a card reader because of a a separate issue, since I upgraded to El Capitan I haven't been able to connect the GoPro directly to transfer files)
 

Cheryl

Rosie Moderator
Staff member
Mod
The transfer of those files were never completed because of the accidental removal of the card reader. They have become broken or corrupt.

You can trash those unix appearing files, empty the trash, start over and transfer those specific files again.
 

Fiddlestix

Registered
Thanks Cheryl,

The problem is that I was backing up these files from the SD card to the Hard Drive and now there are 250 files that are on neither SD or Hard Drive.

Is it impossible to recover the files from the SD card now or do you mean if I remove the Unix file will they reappear somehow?

Thanks.
 

Cheryl

Rosie Moderator
Staff member
Mod
No, they will not reappear. Backing up means you were making duplicate copies. You would have the originals and the backup copy. If you were just transferring or moving from one to the other and you don’t have the originals else where, I am sorry to say you have lost 250 files.

Would a recovery program rescue those files? Hard to say. This is one of the reasons why you need a ‘backup’ copy of important files/folders, whether it is using TimeMachine or another systematic approach to having spare copies. If you try a recovery program - do not do anything to either drive used until you do so.

If you use TimeMachine and did include your SD to it, you may be able to use Time Machine to go back in time to before the transfer and rescue those files from there.
 

Fiddlestix

Registered
I was trying to make duplicate copies, the originals were the ones on the SD and I was copying the files when the card reader was ejected. Don't have time machine set up unfortunately :(
 

Cheryl

Rosie Moderator
Staff member
Mod
If you were duplicating these files, the originals should be still on the SD drive.
 

Whitehill

Registered
Are you Terminal-savvy? If so ...

cd {insert the name of your SD volume}
ls -ld 312GOPRO

Paste the results back here. This will show what UNIX thinks of your file.
 

Fiddlestix

Registered
Not that Savvy but I can use it, when I put in cd NO NAME ls -ld 312GOPRO it comes back with no file or directory. The SD card is called NO NAME and the folder is in another folder called DCIM, should I change what I'm putting into terminal?
 

Fiddlestix

Registered
Still getting no file found, here is a screenshot of what I am doing as well as the contents of the DCIM folder which is on the SD Card NO NAME
 

Attachments

DeltaMac

Tech
The command doesn't find that folder, because you don't have the correct path name to that SD card.
You can get the right setup by typing CD, add one space, then drag the SD card into the terminal window. The correct pathname will be entered then.
Or, you can enter the (corrected) path manually, which SHOULD (I think) be: (assuming the name is, as you say, NO NAME
Code:
cd /Volumes/NO\ NAME/
And, now the secondary command
Code:
ls -ld 312GOPRO
should work.
But, the file/folder 312GOPRO obviously is corrupted. I would not expect to get much from that now.

You could try running Disk Utility/Repair Disk on that SD card.
Or, maybe GoPro has some utility to check files created on their hardware? Maybe that will be some Windows utility, idk.
 

Fiddlestix

Registered
Did a quick 'check info' on the top level folders on the drive and gives a total of 2135 files within folders + 7 files shown. Total of 2142 which is 23 shy of the number shown after the repair. Even after unhiding items there are only a couple more files. Discrepancy somewhere.

Screen Shot 2016-02-14 at 11.36.44 AM.png
 

ViciousMidgets

Registered
@Fiddlestix - did you ever conclude the issue? I ran into a similar problem (noticed after upgrade to El Cap).

Still working on a solution but here is some info I found on the file/directory conversion:

1. The external HD is in fact formatted as Mac OS Extended:
$ diskutil info /Volumes/Ext_HD_1TB/
Device Identifier: disk3s1
Device Node: /dev/disk3s1
Whole: No
Part of Whole: disk3
Device / Media Name: Untitled 1

Volume Name: Ext_HD_1TB

Mounted: Yes
Mount Point: /Volumes/Ext_HD_1TB

File System Personality: Journaled HFS+
Type (Bundle): hfs
Name (User Visible): Mac OS Extended (Journaled)
Journal: Journal size 81920 KB at offset 0x1d1f000
Owners: Disabled

Partition Type: Apple_HFS
OS Can Be Installed: No
Media Type: Generic
Protocol: USB
SMART Status: Not Supported
Volume UUID: 00B78B0E-8ADA-3C3B-89FA-DFABAC7C5AAB

Total Size: 1.0 TB (1000202043392 Bytes) (exactly 1953519616 512-Byte-Units)
Volume Free Space: 884.9 GB (884947746816 Bytes) (exactly 1728413568 512-Byte-Units)
Device Block Size: 512 Bytes
Allocation Block Size: 4096 Bytes

Read-Only Media: No
Read-Only Volume: No

Device Location: External
Removable Media: No

2. Not all of the directories on the drive were affected:
of the 15 directories on the HD, only 3 have been converted to EXE.
ex file:
$ file Ext_Art
Ext_Art: JPEG image data, JFIF standard 1.01
*This was once a directory with images.

3. Viewing the file info via right click > Get Info, reveals a preview of one of the images. :/
Screen Shot 2016-05-11 at 10.12.53 AM.png

So although it would appear that the file is in fact an exe, the preview tells a different story. As to what may have occurred - well since the file was created back in June of '15 and I have a difficult time remembering beyond Monday (of any week), anything is possible. It's very odd that only some of the files were changed. The others are fine.

I will try a few things before throwing in the towel and post my findings.

Cheers
 

ViciousMidgets

Registered
hm - so I just added the .jpeg extension to the file and was able to view the image. ugh - this likely means I cp'd one file of the directory (i was copying from) to the Ext_Art file name thinking it was already created as a directory. Or something like that. Either way, it appears as a non-issue. For me anyway. :/
 
Top