Getting Rid Of Disk Not Ejected Properly Message

nealt

Registered
I have a number of internal disks with different versions of the OS on it. I also have two external disk drives. So when I restart from say a Maverick disk to a Yosemite disk without shutting down any external hard disks I get the alert "Disk not ejected properly" for the two external disk drives. If I close these messages they will reappear later. I know if I shut down the externals then reboot then turn on the externals I will not get the message. But I go back and forth between my Maverick Disk and my Yosemite disk (Internal disks) frequently during the day. I do not get these messages. So how can I avoid these messages?

I posted this on the Apple forum with no response.
 

DeltaMac

Tech
Easy
Change the startup disk, then shut down (not restart).
That process will assure that your Mac does a full hardware initialization - which a simple restart (without a shutdown) may not do.
Goes without saying that you need to give your Mac that time to shutdown, as forcing it to shut off (or restart) can contribute to the problem.

(tip - check both of your externals with disk utility, maybe they are not really working properly
 

nealt

Registered
How do you do a shutdown from the Startup Disk Dialog box? Your procedure requires a lot of time. You must wait for the shutdown to complete then must manually power and reboot. By choosing restart from the Startup Disk dialog box you can walk away from the computer and the computer will be booted up to the new disk when you return.
 

DeltaMac

Tech
Except - your present procedure is giving you questions (and there may or may not be an actual problem. That's why I suggested testing both externals)

The shutdown shouldn't really take a lot of extra time - but it does take one extra step - booting back up. I only suggested that because it can help if the problem is a slow close out of one (or both) externals, and the shutdown is really a work-around. If you don't want to try to prevent the error message, then that's up to you...

Just curious - Can you pin down the difficulty to just one of the drives?

Also, are you booting back and forth because of some issue that you may have with Yosemite?
The new Yosemite update has helped ME with one USB external that sometimes doesn't mount right away, and I get a similar message. I think it's a different fault, but still, I just tested with that drive. I can usually get it to repeat a mounting problem, but since updating to 10.10.2, I haven't seen that. Might be too soon to tell - but I though I could mention that. I also boot between 10.8, 10.9, and 10.10.

Shutdown from the Startup Disk pane is simple. Change the startup disk.
Press Control-Eject, then press enter to accept Shut Down. That shut down box will also accept pressing R for Restart, or S to sleep (if you want THAT shortcut, too)
 
Last edited:

nealt

Registered
Yosemite 10 is still flakey for me so I am still evaluating it on this extra internal drive. I have a 5.1 Mac Pro with 4 internal drives and two external drives used for backup..
So Maverick is the drive I use regularly. These drives appear to be ok by disk utility. This problem also appears when the Maverick disk is selected.OneExternal is Foirewire 800 and one is eSATA.
 
Last edited:

DeltaMac

Tech
Good (small steps, eh?)

Your posts have been a little unclear about which external is giving the problem.
Have you tried leaving just one external connected, as a test?
Are the drives both self-powered, or bus powered?
 

nealt

Registered
Good (small steps, eh?)

Your posts have been a little unclear about which external is giving the problem.
Have you tried leaving just one external connected, as a test?
Are the drives both self-powered, or bus powered?
 

DeltaMac

Tech
You already mentioned both, and I suppose that means both are connected at the same time.
Have you tried each? (one at a time)
As both are using different bus connections, it doesn't seem likely that a hardware problem could cause BOTH devices to drop off line. More likely just one of those devices....
 

nealt

Registered
Both have their own power supplies. It turns out what I am seeing is two messages for the two partitions on the eSATA drive. The Firewire 800 drive does not appear to have the problem. So is there a fix for this?
 

DeltaMac

Tech
How - exactly - are you connecting to the eSATA drive?
External hub of some kind?
PCIe card with eSATA connection?
Something else?
If PCIe card, have you tried reseating that card?
and, if a card, run the Expansion Slot Utility (in the /System/CoreServices folder), which (possibly) will suggest a better slot to use for that card. It's something to try, anyway, just to see what it reports.
 

nealt

Registered
The drive is connected with a PCIe card.

It is seated fine.
Expansion slot utility gives the following message: Expansion Slot Utility is not intended to run on this system.
I am running 10.9.5. Since the drive runs fine otherwise i do not think it is a seating or slot problem.
 

DeltaMac

Tech
Yet - your drive is either dropping off (not unmounting properly) - or a reboot doesn't seem to mount the drive properly.
One of those situations is triggering your "disk not ejected properly" message.
SO - could be the PCIe card (some minor hardware incompatibility with your system), or something is not right about the card itself, or software drivers that OS X is using, or the interface on the external enclosure, or the drive electronics that's part of the hard drive itself.

So - what to do next?
Try the card in a different slot anyway. Move it two slots over.
(why move 2 slots, you may ask? you have two 16 lane slots, and two 4 lane slots, possible that some cards will work more reliably in different slot configuration.)
Do you have any other cards, in addition to your graphics card?
 

DeltaMac

Tech
Just checking for other possible factors...

If the mount problem occurs in both Yosemite and Mavericks, then it could really be a hardware issue with the card (or the drive/enclosure)
Have you checked with the card manufacturer? Their site/support might have information about issues with Yosemite.

Does it make any difference when you put the card in a different slot?
 

ElDiabloConCaca

U.S.D.A. Prime
What exact add-on card is it (brand and model number)? Did you install any drivers for it when you first installed it? Perhaps it has some kind of incompatibility with certain versions of OS X, or needs updated drivers. Does the manufacturer's website outline any issues with OS X?
 

nealt

Registered
Its a NewerTech MAXPower eSATA 6G PCIe 2.0 Controller Card. There are no drivers required. Their customer support says there are no known issues with any version of OS X.
 

DeltaMac

Tech
At the risk of repeating myself -
Does it make any difference when you seat the card in a different slot?
 
Top