How to move files in Finder without using the mouse?

AlanG

Registered
I am trying to move files around between folders in the Finder. I'm amazed to discover there is no Move menu option. There's also no Cut(there is but it's permanently greyed out) although there is a copy/paste. But that means I have to copy the file then paste it into its new home then go back and 'move to bin' (because there's no delete option in finder either!) This is just bizarre! There must surely be a simple way to move files between folders in finder? What am I missing?

BTW. I can't use my mouse because it's acting up and giving false clicks, so the files get dropped in the wrong place or extra files get picked up en-route! I'm waiting on a new one... But surely that shouldn't stop work completely?

Meantime, I've been reduced to opening the Terminal and using unix commands.

PS A final bit of possibly relevant info is that this is all on an external SSD, using a Mac Mini M1. MacOS version is: 12.5.1
 

chevy

Marvelous Da Vinci
Staff member
Mod
I am afraid that the Terminal is the best solution: very fast, reliable... and fully text oriented.

The macOS graphical user interface was never good without a mouse, since 1984.
 

AlanG

Registered
I am afraid that the Terminal is the best solution: very fast, reliable... and fully text oriented.

The macOS graphical user interface was never good without a mouse, since 1984.
Sheesh! OK thanks. I'm glad I was raised on Unix back in the 80s...
 

AlanG

Registered
OK, my new mouse arrived and sanity is restored - at least as far as moving files. I still don't understand why you can't delete a file with the Delete key or why the Cut menu option is greyed out!
 

chevy

Marvelous Da Vinci
Staff member
Mod
Did you try cmd-del ? It does not delete the file but moves it to the Bin.
 

AlanG

Registered
Did you try cmd-del ? It does not delete the file but moves it to the Bin.
Nope! I'd never have guessed that. Did Apple not get the memo about GUIs being intuitive?
But I just tried and it doesn't do anything. I also tried Ctrl-Del and Option-Del and they don't work either...
 

chevy

Marvelous Da Vinci
Staff member
Mod

(I don't know how it works on an extended keyboard, but I do it every day on my MacBook)
 

SGilbert

Registered
Aha! It is Cmd-Backspace not Cmd-Del.
Useful to know, thanks for the pointer.
An Apple compatable keyboard does NOT have a 'backspace'! No wonder you were having problems.
With a compatable keyboard, it IS Cmd-Del.
 

AlanG

Registered
An Apple compatable keyboard does NOT have a 'backspace'! No wonder you were having problems.
With a compatable keyboard, it IS Cmd-Del.
OK, That clarifies things. My keyboard is "dual compatible" in that the keys have the Apple symbols as well as the PC/Unix markings. I use it in a KVM setup so it has to work with my Linux and Windows boxes as well as my Mac Mini. as such it has a Delete key (marked Del) that deletes the character under the cursor (or any selected objects) and a backspace key(marked with a back arrow) that deletes the character to the left of the cursor (or any selected object). I didn't realize the official Apple keyboard had no backspace key. Or is it that it has no Delete key and labels the backspace as Del?
 

Satcomer

In Geostationary Orbit
On moden Macs one go to System Preferences->Keyboard and in pane select t the mini-tab 'Show Input Menu Sources'and put a checkmark in that box to show it menu bar! Once in Finder Menu select 'Show Keyboard Viewer' to see a pop-up to see what key is pressed!
 

AlanG

Registered
On moden Macs one go to System Preferences->Keyboard and in pane select t the mini-tab 'Show Input Menu Sources'and put a checkmark in that box to show it menu bar! Once in Finder Menu select 'Show Keyboard Viewer' to see a pop-up to see what key is pressed!
I can do all of that except the last part. There is no "Show Keyboard Viewer" menu item. I checked all the Finder menus and even tried the various options boxes.
 

DeltaMac

Tech
Hmm... I'm looking at an M1 MBPro, running 12.5.1, so current Monterey.
(Just to clarify what Satcomer posted :cool: )
System Preferences/Keyboard, then Input Sources tab. Click the box "Show Input menu in menu bar"
You should now have a new icon in the the top menubar. Click, and you should see 3 items. "Show Emoji & Symbols", "Show Keyboard viewer", and "Show Keyboard preferences".
What do YOU see?
 
Top