How to UNdisable system volume control when using external soundcard

Mario8672

The Lone Deranger
I recently picked up a new soundcard for my mac and I noticed that it disable's the system's volume control whenever it is set as the default audio output. (the volume up/down keys will not function and the card sets the volume at max).

I've tried routing the audio using soundflower bed, and while this DOES WORK, it often crashes and begins producing loud static until I restart soundflower.

This thread got me wondering if there is a terminal command that can re-enable the system's volume control when using external audio devices or optical outs.
http://hints.macworld.com/article.php?story=20090111110741237

When I bootcamped into Windows, the volume controls work fine even when the card is set to default so I know this is a 'feature' of Mac OS X not the card.
 

Mario8672

The Lone Deranger
I'm using the Audio 4 DJ from Native Instruments. I have the audio running from the card to my stereo speakers. I know I could buy a special setup specifically for listening, but I'm trying to make use of what I have already.

It's an external USB soundcard haha not internal.
 

DeltaMac

Tech
You can make changes to the input/output, by OPTION-clicking on the volume icon in the menubar.
If you are using an optical connection, then I don't know if that Option-click will help you.

And, you are bypassing the system volume when your use a USB sound interface, so the volume can be adjusted at the destination (the amp that controls your speakers. Also, various apps can control the volume produced by THAT app (independent of the system)

Here's a page that has some other viewpoints, as well as using Soundflower:http://forums.macrumors.com/showthread.php?t=899028

You did say that Soundflower doesn't work too well with your setup.
I see a few of those sound-control apps that struggle with Lion, and especially Mountain Lion. Check for recent updates or betas of that software that may fix the stability issues (I don't know what you may find)

Have you tried setting up your NI interface your Audio MIDI Setup (in your Applications/Utilities folder)?
 

Mario8672

The Lone Deranger
I've tried everything with soundflower :(

- setting an aggregate device so that there is only one master clock
- making sure all sample rates are the same
- checking for all updates
- spending endless hours searching for solutions only to find people with the same issue (with any audio card, not just mine)

It seems like this is definitely soundflowers issue, but they've never responded to these concerns in their official support forums.

Which leads me to wonder if there's a way to re-enable system volume control via a terminal command (I know windows doesn't have a problem with this).
 
Top