iTunes and incoming network connections

John Varela

Registered
Every time I open iTunes lately a pop-up asks if I want to allow iTunes to accept incoming network connections. Whether I accept or deny, iTunes goes ahead and runs. The firewall preference of course already allows iTunes to accept incoming connections.

The same problem arose some months (or years?) ago and I believe I corrected it by moving iTunes.app to the trash, then downloading and reinstalling it. That can't be done this time because an attempt to trash iTunes.app in Mountain Lion produces an error message that says iTunes.app "can't be modified or deleted because it's required by Mac OS X". (Why on Earth does OS X "require" iTunes?)

Can anyone suggest a way to override this and delete iTunes.app? Would it be OK to boot from the recovery partition and delete iTunes.app from there?

If not, is there some other way to convince the system to let iTunes accept incoming connections without asking every time?
 

DeltaMac

Tech
Sounds like a firewall setting.
Open your Security & Privacy pane, then the Firewall tab.
Click the padlock and authenticate to unlock. Click the Firewall Options button. Make sure that Automatically Allow Signed Software to Receive Incoming Connections - is checked.
If it is ALREADY checked, then un-check it. Click OK, and restart. Open the same Firewall prefs, and re-check that same setting for Automatically Allow (etc)
 

Satcomer

In Geostationary Orbit
Also check two different angles.

1. Check with Apple at the My Apple ID to see if you can reset your password. Your password may have been guessed and compromised!

2. Also check /Applications/Utilities/keychain Access and check for you iTunes passwords. The entry may have been corrupted and you could delete it to try your password again (again saving the good password to the Keychain), if you already verified it still works through the web site.
 

John Varela

Registered
Sounds like a firewall setting.
Open your Security & Privacy pane, then the Firewall tab.
Click the padlock and authenticate to unlock. Click the Firewall Options button. Make sure that Automatically Allow Signed Software to Receive Incoming Connections - is checked.
If it is ALREADY checked, then un-check it. Click OK, and restart. Open the same Firewall prefs, and re-check that same setting for Automatically Allow (etc)
A reasonable suggestion but, alas, one that doesn't work. I hadn't thought of this possibility so I did try it.

I tried something I found elsewhere on the web, at http://superuser.com/questions/42776/itunes-app-to-accept-incoming-network-connections, with this result from Terminal:

Gandalf:~ john$ codesign -vvv /Applications/iTunes.app
/Applications/iTunes.app: a sealed resource is missing or invalid
In architecture: i386
resource added: /Applications/iTunes.app/Contents/Resources/AdvancedPrefs.icns
resource added: /Applications/iTunes.app/Contents/Resources/AppleTVPrefs.icns
resource added: /Applications/iTunes.app/Contents/Resources/DevicesPrefs.icns

<many, perhaps a hundred or more similar entries>

resource added: /Applications/iTunes.app/Contents/Resources/SharingPrefs.icns
resource added: /Applications/iTunes.app/Contents/Resources/StorePrefs.icns
Gandalf:~ john$

Notice the first line of the response to the command. The blog claims that deleting all of the "resource added" entries will solve my problem. So I duly went to /Applications/iTunes/Contents/_CodeSignature/CodeResources , changed the filename to CodeResources.null, and got this:

Gandalf:~ john$ codesign -vvv /Applications/iTunes.app
/Applications/iTunes.app: invalid signature (code or signature have been modified)
In architecture: i386
Gandalf:~ john$

Any further thoughts?

John
 

DeltaMac

Tech
I think that now your iTunes app is modified, and may continue to give you struggles.
after reading a few threads with much the same problem - I think that updating iTunes through software update (and with ML, through the App Store) _sometimes_ results in minor file corruption in the app itself. In this case, it affects application signing.
And - sometimes deleting a handful of files inside the .app will be a workaround for that issue.
Best to delete iTunes, and then reinstall.
First - Download the iTunes installer.
from: http://www.apple.com/itunes/download/
Don't run the installer yet.
The Finder won't let you (easily) remove iTunes, but you can do that from the terminal by running this command
sudo rm -rf /Applications/iTunes.app
And, reinstall iTunes now.

Maybe the 10.8.3 update will have fixes for this issue...
 

John Varela

Registered
Also check two different angles.

1. Check with Apple at the My Apple ID to see if you can reset your password. Your password may have been guessed and compromised!

2. Also check /Applications/Utilities/keychain Access and check for you iTunes passwords. The entry may have been corrupted and you could delete it to try your password again (again saving the good password to the Keychain), if you already verified it still works through the web site.
I don't think this has anything to do with Apple IDs (though just to be sure, I did check that my old password is valid and I could have changed it if I'd wanted to). Thanks anyway for trying.

Recall that the same problem was corrected for me in the past, with an earlier version of OS X, by deleting and reinstalling iTunes.app. That had nothing to do with Apple IDs. I can't use the same solution now because 10.8.2 claims that it requires iTunes, so won't let me delete it.

Googling on "iTunes incoming network connections" brings up many complaints similar to mine, going back for years. Here is another solution I found on the web:

<quote>
The next solution is what fixed the error from showing up for us. First, launch Terminal (Applications>Utilities>Terminal) and copy + paste the following exactly as it appears: sudo chmod 640 /private/var/log/secure.log. You're going to be prompted to enter a password - type in your password (you won't actually see it being typed, however). Once you do that, quit Terminal.

Next, launch Finder and navigate to the following path: /Library/Preferences. Find the file that is named com.apple.alf.plist and drag it to the Trash. If there is a file named com.apple.alf.plist~orig, drag that file to the Trash as well. Empty the Trash and restart the computer.

Once the computer restarts, open iTunes and check if the error still pops up.
</quote>

I did try nulling the plist files and that didn't help. Since I don't know what that chmod command does I'm hesitant to try it.

John

PS -- I should have mentioned that this problem exists only in my account, not in the other account on this computer.
 

John Varela

Registered
I think that now your iTunes app is modified, and may continue to give you struggles.
after reading a few threads with much the same problem - I think that updating iTunes through software update (and with ML, through the App Store) _sometimes_ results in minor file corruption in the app itself. In this case, it affects application signing.
And - sometimes deleting a handful of files inside the .app will be a workaround for that issue.
Best to delete iTunes, and then reinstall.
First - Download the iTunes installer.
from: http://www.apple.com/itunes/download/
Don't run the installer yet.
The Finder won't let you (easily) remove iTunes, but you can do that from the terminal by running this command
sudo rm -rf /Applications/iTunes.app
And, reinstall iTunes now.

Maybe the 10.8.3 update will have fixes for this issue...
The sudo command did it. Thanks. (Slaps forehead) I should have thought of that myself.

Gandalf:~ john$ codesign -vvv /Applications/iTunes.app
/Applications/iTunes.app: valid on disk
/Applications/iTunes.app: satisfies its Designated Requirement
Gandalf:~ john$

Oh: and regarding Apple fixing this issue, this problem has persisted through both OS and iTunes updates so I don't hope for much from them.
 
Top