Mac Mail Password Errors-can't Get Mail

sandy81676

Registered
Hi,

I'm running Tiger on an iMac G5. I have had no problems with my mail account for the year that I've had the G5..until now. All of a sudden, I can't get my mail from my comcast pop account. It keeps asking for my password. When I enter the password (which I've had for over 6 years), it tells me that it is incorrect. So, I threw away my accounts and rebuilt them. Upon rebuilding, it said there was an error contacting comcast. What's confusing me is, I NEVER changed ANY setting and there was never a problem before a week ago. Needless to say, creating a new account didn't work. I called comcast, and SURPRISE!! they say it's a problem with Mac Mail and not Comcast. I verified my setting with them and they said that they were correct. The incoming is mail.comcast.net and the incoming is smtp.comcast.net - the port is set to the default of 25. If anyone can help, I'd really appreciate it. I really on my email to get homework assignments, credit card statements, account verifications, and updates for software (garagesale updates almost daily). If you need any other info to help me, please feel free to ask. I will keep checking back - but have a lot of hwk. to get done tonight.

Thanks in Advance!

Sandy

PS - my ISP address is www.comcast.net (not .com)
 

bobw

The Late: SuperMacMod
I called comcast, and SURPRISE!! they say it's a problem with Mac Mail and not Comcast.
This isn't true. I use Comcast, and just setup Mail to see if it works, and there's no problem.

I would suggest going to Comcast web mail and changing your password, then change it in Mail and see if it works. If that doesn't work, setup a new account on Comcast web mail, then set that up in Mail and see if it works.

The incoming is mail.comcast.net and the incoming is smtp.comcast.net
You mean outgoing is 'smtp.comcast.net"
 

sandy81676

Registered
Thanks for the suggestions and going through all of that set up for me!! I called comcast and they said that they had just performed a software upgrade in my area which can sometimes "bump" passwords. But, now I can login to my account on the website but not in mail. They are sending out a technician because they think it may be my modem (which is 6 years old) that they have never upgraded. They think that the modem cannot handle the higher speeds so it is timing out. We'll see what happens....I'll keep you posted.

Thanks, again!!

Sandy
 

outerasp

Registered
I have had the same problem with mac mail for the last 9 months.
It is not related to your mail account or ISP. it is a bug in the actual mail application itself. It has something to do with keychain access or possibly the server timeout settings. I havnt found a reliable fix for this yet.

Good luck to both of us.

Jason
 

Satcomer

In Geostationary Orbit
outerasp said:
I have had the same problem with mac mail for the last 9 months.
It is not related to your mail account or ISP. it is a bug in the actual mail application itself. It has something to do with keychain access or possibly the server timeout settings. I havnt found a reliable fix for this yet.

Good luck to both of us.

Jason
What problem Jason? Is you mail asking for your password every time you use it?
 

nrshapiro

Registered
Was there a solution to this for you?

This is happening for me, on ALL my email servers (different servers) at different times. Mac Mail asks me for a password, but it's really another problem, like timeout. I can simply cancel the password box, go to the mail window and take the server back online and it's fine.

I'm running Leopard 10.5.1 on a Mac Pro. Servers giving me problems (all) include my broadband provider mail and two different virtual hosting accounts of mine.

I've read elsewhere that the password prompt is a result of a timeout, or a bug in Mac Mail, but it seems this problem has been around so long, surely there must be a solution?
 

Satcomer

In Geostationary Orbit
Have you opened KeyChain Access (/Applications/Utilities/Keychain Access) and from that application menu select "Keychain First Aid"? This might help, Good Luck.
 

ntack

Registered
I use two Macs, iMac and MacBook Pro, 10.6.5, Mac Mail 4.4 and AT&T DSL. I have had a problem with Mail asking for a password for over a year. Sometimes it works, sometimes it doesn't. I tried everything AT&T suggested (contacted them at least 10 times over the year) and that Apple suggested. Tried all the suggestions offered online. Finally, last week I found that when Mail wants a password, I go online to my AT&T yahoo.com site, log out and log in (same password for the Mail program), go back to Mail and it works. Why, I don't know but doing this causes Mail work for some time without asking me for a password. This may still be a timing problem. Someone at AT&T said I could not have both the yahoo.com mail site open at the same as the Mail program but they both work fine now with both open. Go figure.
 

ElDiabloConCaca

U.S.D.A. Prime
It may be that you have Mail set up to check mail too frequently -- many residential internet providers (AT&T included) don't like customers checking email every 1 minute or so.

Try increasing the interval that Mail checks for mail to 10 minutes and see if that helps in the future, if the problem ever pops up again.
 
Top