Mac not seeing PC shares

nealt

Registered
I have a simple two computer network connected through a wired router. They both access the internet fine. The Mac has lost the ability to see the XP computer shared folders when using go>Network or Connect to server. The PC sees the Mac shared folders fine. I have another partition on the mac with OS X on it. It sees the PC folders fine. All the network settings and security settings are the same on both partitions. What seems to be going on? How can I fix this problem?

Posted with no response in forums
 

Satcomer

In Geostationary Orbit
Well my best way to describe what to do is limited because I don't know what OS x version on what Mac you are using.

I would send you to read the first post in this Apple Discussion and it will walk you through Mac to PC file sharing. Plus the web site MacWindows.com is also a very good resource when putting a Mac in a Windows network.
 

nealt

Registered
I am using 10.5.1 which is where all the problems come from. 10.4.11 on the same computer works fine. If one goes to the Apple forums one learns that there are lots of people out there with this problem with no real solution. Apparently the only way to get it to work is to use smb://x.x.x.x where x.x.x.x is the actual numeric ip address of the PC. One cannot browse.
 

jeno

Registered
Do you installed AppleShare protocol on your windows?
You will need that for PC and Mac to communicate.
 

ElDiabloConCaca

U.S.D.A. Prime
No, you do NOT need to install the AppleShare protocol on the Windows machine. In fact, AppleShare isn't even a network protocol -- it's a software product that Apple produced for Macintosh computers, and it was discontinued back in 2001.

Mac OS X and Windows machines communicate just fine with SMB, FTP, and a whole slew of other protocols. This problem has nothing to do with AppleShare.
 

jeno

Registered
Thanks ElDiabloConCaca for clarification, but that is how i done it with my windows server.

How to you allow Mac to see/access windows shared by not using AppleTalk?

Another way for Mac and PC to communicate is by using ExtremeZ-IP. :)
 

ElDiabloConCaca

U.S.D.A. Prime
AppleTalk is old, dated, and is being phased out by Apple. It wasn't even enabled by default in Mac OS X Tiger.

Yes, in the past (the distant past -- 13 years ago) we had a Windows NT 4.0 server which required "Services for Macintosh" to be enabled in order for Mac clients to be able to see the Windows shares. That was because the Macs did NOT have samba/SMB support, so that was the only way to do it.

Fast forward to now. Mac OS X, for years now, has had native samba/SMB support and can access Windows shares without the need to install anything on the Windows side.

In short, nothing at all needs to be installed on either the Windows computers nor the Mac computers in order for them to communicate. They have everything they need already, out-of-the-box, without having to install ExtremeZ-IP, AppleTalk, AppleShare, Services for Macintosh, DAVE, or any of the other 3rd-party Mac<->PC communication products. While some of those products may make it easier or perhaps offer more configuration options, they are, by no means, necessary in order for communication.

If you want to access Windows shares from the Mac, simply share a folder on the Windows computer, and then access it with command-k in the Finder on the Mac by entering "smb://[ip address of Windows machine]/[name of share]". If you want to access the Mac from the Windows computer, you must enable "Windows File Sharing" (for Tiger and earlier) or "File Sharing" then Options > "Share files and folders using SMB" (for Leopard). Then, do the same thing from the Windows side: open an explorer window, type "\\[ip address of Mac]\[share name]" and you should be good to go.
 

jeno

Registered
Thanks ElDiabloConCaca.

But what do i have to do if i am using AFP connection? How am i gonna set it up?
I try your method and it work perfectly but the problem is SMB connection is crashing our files. I've try to ask around and the suggestion i'm getting is to use AFP instead of SMB.


Cheers
 

ElDiabloConCaca

U.S.D.A. Prime
If you want to use AFP on the Windows side, then, yes, you will have to install 3rd-party software on the Windows machines.

AFP is NOT AppleTalk, though. AFP is "Apple Filing Protocol", and is different than the old AppleTalk.
 

nealt

Registered
I got this from Macwindows.com:
TIP: DNS command-line configuration -- a final answer for disappearing Win shares in Leopard's sidebar?
Monday, January 7, 2008
We've reported numerous varied suggestions for Mac OS X 10.5 Leopard problems with Windows server browsing and file sharing. Some work for some people, and some work only temporarily.
Kevin David found a solution in a blog that involves typing in some configuration commands in Mac OS X's Terminal command-line utility. The blog gave these instructions:
Type this in Terminal:
$ sudo pico /etc/smb.conf
Then add the following line to the [global] section:
name resolve order = lmhosts bcast wins
Save it, then disable and reenable file-sharing from the Sharing panel, checking "Advanced..." to make sure that SMB is enabled. After a minute or two, your Shared should be back in the sidebar.


It worked for me.
 
Top