Maps, interactive ... is there something corrupted in Safari?


I've been having this issue for some time on my Mac Mini. I've tried turning off extensions, checking permissions, etc. And I can't figure this out. When I try to use Google maps or for example, this is an interactive map from NY Times, I get an image like this ... or in the case of Google Maps, just a black screen with a line through it. This does not happen on the laptop, and both have the latest Monterey on them. It doesn't happen on the iPad or iPhone either.
I tried to delete the Safari app using "AppZapper" to delete everything (supposedly) and nothing changes, after reboot. (What I should see is below the first image)

PS This doesn't happen in Microsoft Edge, Chrome or Firefox. So, Safari is my default, but if I want to use anything that has maps involved ie searching for hotels, anything interactive, like this map, I get this weird line and have to copy and paste the url into another browser.
Screen Shot 2022-10-08 at 12.23.00 PMEDT.png


  • Screen Shot 2022-07-09 at 2.07.31 PMEDT.png
    Screen Shot 2022-07-09 at 2.07.31 PMEDT.png
    547.8 KB · Views: 5


I don't think so. I turned off Ghostery, Adblockers. Only one that shows up as an extension is Ad Block Plus and I turned that off.


Rosie Moderator
Staff member
When Safari is acting badly for me:

Go to Develop > Experimental Features > Reset All to Defaults (which you need to scroll to the very bottom of that loooonnnng list).


Will give that a go. Where's "Develop" hidden again? (Never mind: Found it)

Update: Oh, well, good idea, nothing. So, right now ... it seems that this is now only happening on one website, the NY Times Interactive Map site ... the google maps and other sites that were acting up seem (operative word) to not be doing it anymore. And the NYTimes Map is only acting up on the Mac Mini, not i phone or iPad. So... if this is the only problem at this point, who knows? As we know, Safari is often the last thing they build for ... though Safari is what's on the phone and pad, but different OS ... thanks for the hints and help, but unless it starts showing up again, I'll assume everything's fixed (Now, watch, it will start acting up again :)
Last edited: