messed up computer (10.9.3) after migration to SSD - permissions or java problem?

roninsmurf

Registered
thanks in advance for reading! I have a doozy: I moved my hdd to my optibay and installed a new SSD into my main hdd bay (mbp late 2011)
transferred data from hdd to ssd using superduper
so the ssd is now a clone of the old hdd (and in the same place as the old hdd) and the ssd is the startup
BUT
seems permissions are wonky?
not sure what it is. possibly java is a problem -- maybe via permissions?

here's the symptoms:
browsers/finder work great (faster with ssd)
but MANY apps just wont load or are wonky.
bluestacks won't load-- wont even get to the "loading" animation... (have re-installed numerous times)
metasearch on vuze won't work -- I see it for 7 seconds and then it vanishes.
other apps wont load -- the problem seems to be java related maybe? I'm not clear.

steps I've taken to resolve:
(all did nothin)
re-installed every app that wasn't working (ug! endless! appcleaner etc! hard to say how far they were uninstalled but seemed pretty thorough)

re-installed OSX 10.9.3

repaired permissions in a few ways on ssd

even "Reset Home Folder permissions and ACLs" via rebooting with cmnd+r

downgraded to java 6 (did nothin) then back up to java 7 (nothin)
erased all the java caches etc I could find

now I'm not really sure WHAT is going on here -- but my suspicion is that there's something funny about the superduper migration and permissions (everything was working when I upgraded to 10.9 a month ago)
I noticed: when I open a lot of folders, like utilities etc, they're read-only. huh? I don't think that was true, before.
to fix this I made the possible mistake of GetInfo/giving read-write privileges to everyone and "applied to enclosed items"
maybe that was dumb?
either way, after rebooting and repairing permissions, it seems the read-only structure of much of the new ssd is back
(I'm logged in as my main account as always -- is this not root? I'm never clear on root stuff...) (with mavericks, before the migration, I was able to run all these apps fine. but none of these odd "read-only" icons were showing up in my folders)
so maybe bad permissions -- or bad java -- is the reason apps won't connect to the internet? sometimes they crash when running animations.

ANY help would be so appreciated! already wasted many full days on this! ack! :eek:
 

DeltaMac

Tech
You may find that your easiest method to get your system working again is to boot to your recovery partition, and reinstall OS X. That will reinstall OS X on top of what's there now, without deleting or erasing anything. It should fix up your permissions problems, which you likely only made worse.
Current version is 10.9.4, so run your software update to check, once your reinstall is complete.

Try to ignore your need to use a get info window to "fix" permissions on random folders. It can sometimes result in borking your system, particularly if you do that to random folders, without knowing exactly what you are doing.
All you should need to run a Repair Permissions, from Disk Utility, then check that you own all the files and folders in your own user. There's a one-line easy terminal command for that, if you need to know how to check for ownership for your own files and folders.

final note - a default user account in OS X will be an admin account, but will not be a root user account (which is a step above an admin account). The root user should NOT be left enabled, so you might check that the root user is disabled.
 

roninsmurf

Registered
thank you DeltaMac!!! :)
sadly, I have already tried your first (alpha) idea. :) I re-installed OSX (you're right -- 10.9.4) yesterday after pressing cmnd+r on restart.
it didn’t delete or erase anything, which was much appreciated, but it also didn’t fix any of my problems :(
again, I'm not sure if this is a permissions issue -- just that upon moving to the SSD, many of my applications are messed up.

so: I have re-installed 10.9.4
and: I've Repaired permissions over and over.
even "Reset Home Folder permissions and ACLs" via rebooting with cmnd+r and using terminal to get to that (nearly secret) screen.

as for your thought: "check that you own all the files and folders in your own user. There's a one-line easy terminal command for that, if you need to know how to check for ownership for your own files and folders."
I'm not sure what this means?
do I "own" the files and folder? I'm not sure what to say?

as I mentioned, I have found it very odd that many folders are now "read-only" (including applications folder+ utilities + /Library/) (why would this be the case? permissions mistake?)

thanks for your explanation of "root" -- I guess I was thinking that being the root user would allow me to run my applications better (which are maybe wrestling with these "read-only" support files?) -- but I'm clearly just guessing at this.

any other thoughts? have I understood your advice correctly?
 

MisterMe

Registered
Permissions are not some magic file attributes that are damaged for mysterious reasons or that require incantations to repair. Each application's permissions settings are maintained in the /Library/Receipts/ folder by the.pkg bundle that was created when the application was installed. To repair permissions is to restore your permissions settings to the values in the application's receipt .pkg bundle.

If your diagnosis of permissions problems is correct [and it usually is not], then you did not clone everything when you moved your files to the SSD. Among the files not clones were those in /Library/Receipts/. If this is the case, then there is nothing to tell the System what your permissions should be when you try to repair them.
 

Satcomer

In Geostationary Orbit
Do you know your hard drive's name? You will need the name in place of YOURHARDRIVE:

Code:
[COLOR=#333333][FONT=Lucida Grande]sudo chmod 777 /Volumes/YOURHARDDRIVE
[/FONT][/COLOR]Then press return and put in your password and let it run until you get another prompt. After it finished immediately reboot your Mac and this should help your situation.
 

roninsmurf

Registered
thank you misterme -- so does that mean I should erase the library/receipts on the SSD
and re-copy the folder from the old HDD?
(I get that this is not magic ;)
 

roninsmurf

Registered
thank you satcomer!
I googled what chmod777 does -- seems a bit scary
this would (kinda arbitrarily?) convert all the files on my SSD to read/write, yes? is that a good thing? wouldn't that get me into a mess of changing files that SHOULD be read-only? (although I see no reason why anything should be read-only on my computer -- but I clearly don't really get these concepts fully.)
I'm worried this would be like saying "apply to enclosed items" on the get info panel -- which might make my problems worse? (or am I mixing up "permissions" and "read/write")

I do like the idea of having read/write access to everything -- but I'm confused as to why it was switched anyway (superduper error? mavericks bug? natural result of migration?)
if you have the time, could you explain why you feel that chmod777 is a good idea? many thanks! :)
 

roninsmurf

Registered
to be clear: folders that are read-only: (tho the folders enclosed therein may not be) : ssd main volume folder users system library utilities

applications and documents/movies/etc seem to be read/write ... which is what I'd expect.

could this relate to my applications aborting and not connecting? I'm clueless. just a guess - cuz again: most of my problems seem to be related to things that animate or connect to the internet (so maybe java?)
 

MisterMe

Registered
thank you misterme -- so does that mean I should erase the library/receipts on the SSD
and re-copy the folder from the old HDD?
(I get that this is not magic ;)
No, I am not saying erase anything. I gather that /Library/Receipts/ was copied along with everything else from your old HDD. I am, however, even more skeptical about your diagnosis of permissions problems.

Earlier this year, I had cause to replace a Power Mac G5 with a compatible model. The new computer had to be back online and fully-functional as soon as I had jacked-up the old computer and slipped the "new" one under it. This is what I did:


  1. I used Carbon Copy Cloner to make a complete bootable clone of the old computer's hard drive on a MacOS Extended (Journaled)-formatted external drive connected by Firewire. The Firewire-connected drive is named Backup Drive.
  2. I rebooted the old computer into the cloned OS on Backup Drive. I tested several applications. Everything worked as well from Backup Drive as they had from Macintosh HD.
  3. I replaced my old computer with the "new" one.
  4. I booted the "new" computer from its internal HDD. No problems.
  5. I connected Backup Drive via Firewire and rebooted into its cloned OS.
  6. I launched Carbon Copy Cloner and made a complete bootable clone of the software on Backup Drive on the "new" computer's internal drive, Macintosh HD.
  7. I rebooted the "new" computer into Macintosh HD.

With three exceptions, the "new" computer was indistinguishable from the old one. Two exceptions are applications that require activation. Reactivation requires a phone call to their developer. The third is Microsoft Entourage 2008. Entourage required a rebuild of its database, a known issue with the POS.

There are obvious differences between your situation and mine. However, those differences should have no bearing on your problem. Satcomer and I are both giving you the benefit of our years of Macintosh experience. My speculation about your Receipts folder is apparently wrong. Satcomer's speculation about the name of the SSD is also not the cause of your problem.

At the moment, the only thing that I can think of is your SSD's file system. Apple gives you several choices of file system. The file system on your SSD should be the same as that of your original internal HDD. The drive in my MacBook Pro is formatted MacOS Extended (Journaled), the first selection on the Disk Utility>Erase pop-up menu. I assume that this is the file system that shipped on your Mac's internal HDD.
 

roninsmurf

Registered
thank you misterme, for you thoughts.

the way you describe your migration process sounds a lot like my process.
here's a rundown of mine:
used superduper to make a full clone of the internal mbp2011 HGST HDD onto an external LACIE firewire HDD.
Still connecting the LACIE by firewire, restarted the computer/ booted from the external LACIE (via firewire) and checked that everything worked. It did -- tho admittedly, I did not run EVERY application -- just ran osx + firefox and saw that all my data files were where I'd thought they'd be. ran ms word, too, I think.

Then: moved HDD into optibay.
(Then: endless process of having to "downclock" the speed of the HDD to run in the optibay (ugggg) -- had to re-install the optibay etc + then take it back out-- rough.)
then: put the new SSD into the main-hdd-bay.
then used superduper to copy the HDD onto the SSD
used a superduper script that said: "DONT INCLUDE the movies data/or itunes folders" -- planning to keep those on the hdd.
and voila. had a supposedly perfect clone of the HDD (minus movie/itunes files) on the SSD, which then booted fine and seems normal except for the weird read/write issues and the odd application behavior.

could using the superduper script that omitted copying the itunes/movie files have done something bad?? seems very unlikely to me. (I've used the same script many times before -- it's part of superduper's process.)
it seems unlikely that the script is at fault, as well, because now BOTH the HDD and the SSD have odd "read/write" rules. (maybe because they were moved and that makes stuff go nuts??)
I fixed the HDD odd authentication-requests (requiring password to simply move movie files etc) by opening getinfo+ checking the box "ignore ownership on this volume". done. but that was on the HDD -- there seems to be no such box for the SSD/startup volume.
(again, the folders that have required authentication / read-only (which never happened before) are now all on the SSD, and they are:
ssd main volume folder ...users ....system ...library ...utilities (not applications)


none of the messed up applications require re-activation. all are freeware. and: oddly: reinstalling them has not helped! so bizarre!
and I worked pretty hard on REALLY unistalling (using appcleaner etc)
intriguingly, when I UNmount the HDD, and booted apps from the SSD, some apps allowed a bit of animation to their loading screens (which they DIDNT at first when they were failing to load -- hence my fear that this might relate to java) but then still ... the apps did not load/work :( (so this means...? some messed up pathways related to the HDD being mounted?)

trying to load these applications from the HDD/in the optibay also fails.
and oddly: trying to load these applications from the LACIE external HDD also fails! huh. (still a pathways thing?)
I have an old backup from a week ago (on another external HDD) and that works fine... loads all the apps when you boot from it...

also: repaired permissions and ran DiskWarrior on both -- no effect
(would doing a "scavenge" rebuild of the desktop via diskwarrior help?)


lastly, to your point:
both file systems for the HDD and the SSD are Mac OS Extended (Journaled) -- on the HDD and the cloned SSD
but this raises an interesting point -- when I upgraded to Mavericks from SnowLep, I had to "turn on journaling," which maybe could've gone wonky? not sure.
I "converted" my hdd to "journaled" and then used mavericks with no problems on the hdd for a month.
then, with the moving these drives around and such, that's when the difficulty began. :(
 

roninsmurf

Registered
and misterme, as I understand satcomers chmod advice, it's not about naming.


>Do you know your hard drive's name? You will need the name in place of YOURHARDRIVE:

Code:

sudo chmod 777 /Volumes/YOURHARDDRIVE

Then press return and put in your password and let it run until you get another prompt. After it finished immediately reboot your Mac and this should help your situation.



from google:
chmod 777 file change the permissions of the file file to read, write, and execute for all.

so I think he's saying I run the chmod command with the name of my entire drive, to make the entire drive read/write.
this seems scary, but I'm not clear on how permissions work...
 

Doctor X

Registered
Sneaks in, grabs a glass of wine and a sandwich

I will not pretend to have a better ability to diagnose your problem better than those who have responded BUT from what you have written you indicate that you used SuperDuper! to clone your drive. I also use it, and I have never had a problem with booting off of a clone from it. Unless you copy a damaged volume.

SO.

Make sure, somewhere, you have your original "You." Even if it is on the Internal HD you swapped out for you SSD. That is "you" as in data. Getting an external enclosure for it to make it a glorified external drive is dirt [CENSORED--Ed.]ing cheap.

I would also add you should have an regular External Drive to use as a cloned back up via SuperDuper! or Time Machine.

Why?

Because when you test a solution suggested to you from, say, Satcomer, and if it does NOT work, and you get a mess--ON your SSD--you can simply boot from your SOURCE--be it your previous Internal HD and/or External HD--and pretend nothing happened. You can then reclone from the Ex-HD to your Int-SSD and start over. Hell.

And you should get use to doing this. Sometimes, the Newest Most Awesomest OS update BORKS Programs You Need. This is not a problem if you have cloned yourself previously.

Sneaks away in pursuit of one of the maids . . . "Everybody Ought to have a Maid!"

--J.D.
 
Top