Messed up my wife's Mac Mini

Scott Mcllarky

Today I tried to set permissions on my wife’s mac mini HD (Snow Leopard) to be read and write accessible to ‘everyone’ and clicked the option for it to ‘apply to enclosed items’, after which I got the horizontal barber poll, and after about 15 minutes got a pop-up alert that something wasn’t installed correctly (I really don’t remember what it said), and when I clicked to close it, there was another similar alert about a different file/extension, then another, and another. Clearly my trying to set the permissions that way had caused all these alerts. After clicking out of about 40 of the alerts, I decided to just force shut down the machine, and I haven’t been able to get it to boot up normally since. I get the logo screen with spinner and it never goes any further. I have a Windows Boot Camp partition and I can boot into that and work in Windows just fine.

Here’s what I tried to no avail:

Safe Boot – I get the progress bar under the logo, which gets to about half-way then disappears and nothing more happens.

Booted into Single User Mode and ran /sbin/fsck –fy. Got “Macintosh HD appears OK”

Booted to the install CD, which is OS 10.4.10, and ran disk utilities to repair disk, verify disk, repair permissions, verify permissions with all checking ‘ok’.

Reset the PRAM several times in a row.

Tried to reset nonvolatile firmware, and I just get the logo and spinner – no command line prompt.

The only other suggestion I’ve found it to “test the kernel” by reinstalling the OS. Unfortunately, I do not currently have the Snow Leopard upgrade disk, and if I were to reinstall, would that delete all my files on the HD?

Any assistance would be GREATLY appreciated as I am typing this from the proverbial doghouse.

Thank you, Scott


In Geostationary Orbit
On any OS X retail install disk you can do an "Archive & Install" feature (in the Advanced install functions) where it will just replace the system files. This Apple discussion document labeled Step by Step to fix your Mac might help.


Snow Leopard (10.6.x installer) does not have an optional "Archive & Install", but will reinstall a fresh system, without needing to erase the hard drive.
You did mention that you don't have the Snow Leopard DVD. Reinstalling OS X 10.4.10 on your system WOULD give you the option for an Archive & Install, but likely won't help, or probably won't even install without erasing the hard drive (because of the Snow Leopard system installed now).
I'd say that you have probably made things worse (if that's possible) by repairing permissions while booted to the 10.4.10 installer.

My suggestion is to find your Snow Leopard installer DVD, and boot to that DVD, and do a reinstall. I'm not sure if even that will get you going. You may need to erase and install again, and then restore everything from your backup - this would be one of those times when a full backup would be a Good Thing™...

Scott Mcllarky

Thank you folks for your responses. Those give me some options. I should have also mentioned that I have an iMac with SL, if that opens up any options.