networking two imacs with firwire cable

AGG

Registered
Hi, I have two imacs in the same room and am setting up networking. I have bought two firewrie cables and a repeater to connect them to make the distance. My question is - how do I activate it? When I turn on the computer I'm supposed o do something really simply but I've forgotten the instructions. I just want to file share between computers and use programs installed on one throught the other. I'd love to be able to use the internet on both but I was told that the firewire cable had to plug into the internet port.
 

elander

Registered
All you have to do is to enable "IP over FireWire", and if you look in System Preferences > Network, you should see that you now have a new network port. Just activate DHCP on that port on both computers, and they'll find each other. You can still use Internet on both machines, the Mac OS can handle any number of networks and network interfaces.

If you only have one internet connection, connect it to one of the computers, and then activate Internet Sharing in System Preferences > Sharing > Internet. Tick the tick box next to FireWire in the list and everything should be working immediately.
 

sgg

Registered
Nice, so how do you enable "IP over FireWire"?
 

DeltaMac

Tech
That was it -
Open Network pref pane, Check in the Show list for Built-in FireWire (or FireWire over IP, I think in older OS X), or go to Network Port configurations and enable it there if it is listed. Click on New if it is not listed, and click on Ports, then Built-in FireWire, and OK. That should do it... If your OS X is older than 10.2.something, then you won't have that as a choice. I'm not sure exactly what version added it, but 10.2.x is a good bet.
 

sgg

Registered
Sounds simple. However, I'm having a hard time logging onto firewire connected workstations.

I've connected 2 G5 workstations via built in firewire 800 ports. One is 10.4, other 10.3. On both systems, i've added firewire port configs in "Network".

Also, I've turned off the firewall for both stations.

I've tried leaving them both as DHCP.
I've tried assigning IP addresses manually as well (192.168.1.102 , 168.196.1.101).
All of this has given me the same result.
At each station, I can see the other in the network list, but i can't log on.


Failed to connect message on the 10.4 machine:
The server may not exist or it is not operational at this time. Check the server name or IP address and try again.

On the 10.3 machine, I just get a timeout countdown leading to failure to connect.
 

ElDiabloConCaca

U.S.D.A. Prime
Have you turned on "Personal File Sharing" in the "Sharing" section of the Sytem Preferences?
 
Top