Safari 9.0.1 (10601.2.7.2) And Canon Site


I just recently had some problems with my Canon printer so when I went to Canon's site to download and install drivers. I found I couldn't get the buttons (search, drivers and downloads etc.) to work. I tried it with Firefox and the site worked as intended. Is there any setting that I need to enable/disable in order to go through Canon's site? AFAIK it worked fine in previous Safari versions.
I don't know, Satcomer. I have the latest version of Flash installed and JavaScript enabled in Safari Preferences. Canon Canada works fine, it's Canon USA that I'm having problems with.
That's one of the reasons that I keep multiple browsers.
Some sites just go wonky, over time. Just ran in to another one yesterday that would not work with Safari, no scrolling, no buttons, weird black bars.
So, works fine with Firefox. I also use Opera for troublesome sites.
I think it's often a case of site maintainers who forget that Safari is *still* an active browser :D