Safari won't display YouTube Homepage properly

bjr001

Registered
Hello,

Safari (ver. 12.1, Mac OS 10.13.6, Pro Mac early 2009) began displaying the Youtube homepage with most of the video windows blacked out. If I'm logged in it displays more than if I'm not logged in. Other than that youtube works fine. If I click a video it goes to the video fine. The right pane showing other videos display the other video windows fine.

Thanks
 

ScottW

Founder
Staff member
Have you installed an Ad Blocker in Safari? If so, that will cause the block boxes on some videos on YouTube home page, unless you expressly disable ad blocking on the home page.

If not Ad Blocking, what extensions do you have installed in Safari?
 

bjr001

Registered
Hello

Thanks for the reply. I don't have any extensions in Safari - nor ad blockers. I deleted the data (cookies, etc) for youtube but no change. I also deleted the entire history with no luck.
 

ScottW

Founder
Staff member
Can you take a screenshot of what you are seeing? Just load up the page and use the keys COMMAND-SHIFT-3 for the whole screen or COMMAND-SHIFT-4 then hold the mouse over the safari window, press the space bar, then left-click the mouse. This will take a picture of Safari window only. Then attach it to this thread.
 

ScottW

Founder
Staff member
If you hold down the shift key, while clicking the refresh 3/4 circle icon (on the right side of the URL) does that load more images?
 

ScottW

Founder
Staff member
If you hold down the shift key, while clicking the refresh 3/4 circle icon (on the right side of the URL) does that load more images?
Did you try the above?
 

bjr001

Registered
I logged out of my working account and logged onto my admin account. In the admin account youtube works just fine.
 

DeltaMac

Tech
Try deleting Safari's caches. You can do that from Safari's Develop menu (Empty Caches)
If you don't show the Develop menu, you can turn that on from Safari's Preferences/Advanced tab.
 
Top