Slow Wireless on PowerBook fast on iBook

rsjm

Registered
I have the D-Link 514 wireless router. The thing works great with my old clamshell iBook which surfs the web at least three times as fast as my brand new PowerBook G4 which is equally as fast as the laptop it replaced (PowerBook Wall Street). What gives?

The only difference I know is the Airport vs. Airport Extreme but that shouldn't affect things right?

Anybody have some hints for router settings or anything to get the PowerBook up to speed?
 

LeeWhitt

Registered
A shot in the dark, but in the "Energy Saver" options in "System Preferences" for the Powerbook, you have multiple performance optimization defaults.

If, by chance, you have the Powerbook set for optimal battery usage, the Powerbook will cut processor speeds to extend the battery life.

Additionally, in the Airport menubar icon, if you have "Use interface robustness" on, the Powerbook will sacrifice WiFi speed for connection stability.
 

rsjm

Registered
Both of those were "off". Thanks though.

Anyone else have any ideas?
 

owen-b

Registered
I have the exact same problem - my iBook G3 600 MHz with regular Airport connects perfectly well to our new DG834G Netgear router wirelessly, but my girlfriend's brand spanking new 15" Powerbook running 10.3.9 and Airport Extreme is running very slowly, dropping bars down to 1 at times, but never making it to full. MacStumbler shows it as having at most 40 for connection, whereas my iBook gets up to 90 most of the time.

Her 'robustness' is off but no difference made. Will check her 'battery optimum' now...

Nope, made no difference as far as I could see.

We've swapped channels from 11 to 10, 9 and 1, nothing changed.

Owen
 

owen-b

Registered
Sorry to bump this up but it seemed more sense than starting a new thread. Still having the same problem with the Powerbook. Any suggestions, gurus! :)
 
I don't know if you've tried this but if you go under System Pref and Network,
make sure that airport is at the top of the list in Network port Configurations. I know it helps for Me.
 

owen-b

Registered
Okay will give that a try... It was at the very bottom of that list so I've moved it to the top but no instant leap in bars on her reception indicator.

How does that work, then? Surely being at the bottom of a list doesn't prioritise reception, especially when the airport is the only receiver of internet on the machine (no ethernet etc connected)?

Owen
 

ElDiabloConCaca

U.S.D.A. Prime
No, but it does prioritize the order in which network interfaces are "looked at" when a network request is made... first gets looked at first, second... second, etc. If your AirPort is at the bottom of the list, then the slowness could be due to the computer having to look through all the other network interfaces before it tries wireless, but I don't think that's going to affect things THAT much...

If you do a steady download of a large file with some program that reports kb/sec rates, does the PowerBook download slower (less throughput), or does it just take longer to "ramp up" to a fast speed (more latency)? If the latter, changing the order of network interfaces may help... if the former, I don't think network interface order is the problem...
 

owen-b

Registered
It's more that sitting side by side, the Powerbook struggles to get a full signal while the iBook get's full. Go next door and the Powerbook get's NOTHING and all internet applications show an error message, while the iBook is at full.

Used MacStumbler and the iBook is operating at 80-90 reception with about 20-30 noise, while the Powerbook is operating at best 40 reception with no noise.

Owen
 

matthewT

Registered
the problem is due to the metal casing that is used in the powerbook...
from what i hear the only way to fix this is to buy an external wireless card...
i have yet to do so, but a classmate of mine also has a 15" pb g4 and he bought one and now gets amazing reception while i, sitting right next to him, get at most one bar...which usually fades out
 

owen-b

Registered
I'd heard rumours about this - what a shocking oversight on Apple's part not to have done something about this? What's the point making a superfast Airport card if you house it in something that dampens the signal? That's like Superman making his windows out of lead!
 

Jason

Eyebrow Moderator
It's plainly just the difference between the two's build materials...
 

owen-b

Registered
Well it's not that plain. It's the last thing I'd have thought of. See my previous post on the ridiculousness of building a machine with materials that dampen the signal of the wireless card that it, proudly, ships built in.

Stupid Apple.
 

cnk_coleman

Registered
There are many things that can cause wireless slowdowns.

Distance from the node. It has to do a checksum to make sure all the packets got through. If they fail then they have to be resent. The further you get away the worse it will get. Even if you are close to the node walls and other physical obsticales can cause problems. Walls with rebar are the worst.

WEP or WPN security will slow down a system. This just taks more time to send data. If you turn it off you will see the system speed up.

If you have selected signal rubustness this will have a big hit on performance.

And last but not least the Apple computers look real nice but form does not always equate to function. The wireless antennas in the Apple laptops really suck. They are either not tuned or there is interference in the metals near the antenna. My G4 Tibook is not even close to the performance of my older Pismo (Titanium versus plastics).

Chuck
 

cnk_coleman

Registered
owen-b said:
Okay will give that a try... It was at the very bottom of that list so I've moved it to the top but no instant leap in bars on her reception indicator.

How does that work, then? Surely being at the bottom of a list doesn't prioritise reception, especially when the airport is the only receiver of internet on the machine (no ethernet etc connected)?

Owen
The position on the list just tells the system where to look first for a connection. I use Ethernet, Airport and then modem. From fastest to slowest.

It has nothing to do with speed.
 

texanpenguin

Registered Penguin
This might sound like an odd suggestion, but perhaps if you rotated the PowerBook by 90°?

The reason being, the PowerBook G4 has two little plastic sections on the vertical section of the screen (you can see them along the side) for the AirPort antennae, and it can receive significantly stronger signal through those than through the Aluminium.

Another idea is to make sure you have the latest AirPort drivers (since they all tend to increase signal strength). I also have a Netgear DG834G and it went from 1-3 bars fluctuating to constant 5 bars with the AirPort 4.2 update.
 

TommyWillB

Registered
Are they each configured the same way:

1) Are both using static or DHCP IP addresses?
2) Do both have the same DNS servers listed in the same order?

DNS lookups definately can slow things down if the first couple servers listed are not working...
 

TommyWillB

Registered
Also note that if you run and AirPort and AirPort Exteme machine at the same time the Airport (router) itself will slow down to AirPort speeds... However it might have to do extra negotiation with the AirPort Exterme enabled machine to get it to communicate at the slower speed. The Airport machine will do that by default and not need the extra negotiation.
 

karly

Registered
The metal case cetainly may be the issue, but here's another suggestion.

802.11b (airport) and 802.11g (extreme) share the same frequency, so might be interfering with each other. If you can put the router into 802.11g only mode, try it and see if the exterme connection gets a lot better (of course, the airport connection will go away, but this is just a test). If this improves things, I'd check with the router manufacturer to see if they have suggestions.

also, some cellular phones, and microwaves can interfere with thse devices, but since you are seeing consistently bad connections, this probably isn't the issue.

-karl
 

Carlo

All your base are belong
If you have a 802.11g Access Point it will runa t B too but it does this on the same channel as G. It wont cause interferance as its the same network..

When you run 802.11g, as soon as a 802.11b computer joins the fun the whole network does slow down quite a bit. Which kinda sucks. I wish apple supported 802.11a as its a much better protocol.

if you have seperate ap's for 802.11b and 802.11g then you should definatly be running then at different channels. and make sure their is no overlap in the chanells. All you can really use is 1 6 and 12 (in australia anyway)..

I would walk right up to the access point and see what your signal is like.. Then start walking away and what if it goes down quickly. It might be that there is something causing reflection of the signal which was not effecting the lower speed 802.11b.
 
Top