Something like a character map?

ScotchAngel

Registered
I recently purchased a macbook and I was wondering if there was something like the window's character map?
Something with icons such as musical notes and hearts and things like that.
I've looked all over the place for it and I just can't seem to find it. >.<
 

Mikuro

Crotchety UI Nitpicker
Yes, there is. To access it, you need to enable the input menu. Open System Preferences, and go to the International section. Go to the Input Menu tab, and check the "show input menu in menu bar" tab. Also make sure that "Character Palette" is checked in the list at the top.

Now you can just select Show Character Palette from that menu from anywhere. You can drag and drop special characters from the palette into any text field in your apps, or copy and paste.
 

ScotchAngel

Registered
I actually tried all that.
And then called the Mac help line, but was disconnected and then it closed..
But from the way the woman made it sound, there is actually some issue with my software so the character palette isn't on my computer. :(
 

Mikuro

Crotchety UI Nitpicker
Ah, okay. AFAIK it's a standard part of any OS X installation, so that's surprising. Can you tell me which part of what I described doesn't work on your system? For example, are the options I mentioned in the Input Tab not there on your system, or does the menu never appear, or does the menu item just not work?

There's another way to open the character palette (although it's kind of weird), and that's to launch the file manually. In the Finder, under the Go menu, select Go To Folder, and enter this:
Code:
/System/Library/Components/CharacterPalette.component/Contents/SharedSupport/CharPaletteServer.app/Contents/MacOS/
There should be one file in that folder, called "CharPaletteServer". Double-click it and see what happens. It should launch an application called Terminal and then display the character palette.
 

DeltaMac

Tech
There's a lot of methods to get the character window up on your screen, which is what you are asking for.
Here's just one alternate.
Open your Text Edit app, or most anything else that might offer an app font window.
Go to the Format menu(some apps may have a Font menu instead), and choose Show Fonts. Click on the 'gear' icon at the bottom of that Fonts window, and choose Characters...
And, there's your characters window.
You should also then see the Special Characters... added to the bottom of any Edit menu that you use. And that's another way to access your characters.

add - Ah, Mikuro, good choice! That gets to the heart of the matter quickly....
 

ScotchAngel

Registered
As per the instructions of the hotline lady, who was actually helpful until my phone cut off. >< I put the little flag icon to show in my status bar, but when you pull it down there's nothing about the character palette.

And I tried all the other ways you described... there's nothing about it. Like it doesn't exist... Which is odd. @_@
 

NoWake200

Registered
As per the instructions of the hotline lady, who was actually helpful until my phone cut off. >< I put the little flag icon to show in my status bar, but when you pull it down there's nothing about the character palette.

And I tried all the other ways you described... there's nothing about it. Like it doesn't exist... Which is odd. @_@

This is the EXACT same thing that is happening to me. I feel like I am loosing it, this seems very simple but for some reason I can not get the special character to work.
 

NoWake200

Registered
Ah, okay. AFAIK it's a standard part of any OS X installation, so that's surprising. Can you tell me which part of what I described doesn't work on your system? For example, are the options I mentioned in the Input Tab not there on your system, or does the menu never appear, or does the menu item just not work?

There's another way to open the character palette (although it's kind of weird), and that's to launch the file manually. In the Finder, under the Go menu, select Go To Folder, and enter this:
Code:
/System/Library/Components/CharacterPalette.component/Contents/SharedSupport/CharPaletteServer.app/Contents/MacOS/
There should be one file in that folder, called "CharPaletteServer". Double-click it and see what happens. It should launch an application called Terminal and then display the character palette.

This worked! Thanks for the information!!

Kind of strange the two of us had this problem.

ADDED

Ok another problem, when I close the Finder the Special Character also goes away. Is there a way to keep it without having to do this every time?

Thanks for the help.
 

Satcomer

In Geostationary Orbit
Well the Character Palette can be shown if you open System Preferences (the one in the Dock)->International and once that opens pit check marks in "Character Palette" & "Keyboard Viewer". Then scroll down and put a check mark in your countries flag.

Once the flag of your country appears in the right hand corner (right next to the clock) you can click on it to drop it down and there you can start the Character Palette". This will bring up the palette and it will input a character when you double click on a character.

The "Keyboard Viewer" will give you a palette that will show you a graphical view of each key you peck.

This stuff is not hard and it sounds like you are making this harder than it really is.
 

NoWake200

Registered
Thanks for the reply. But for some reason this is not working. The only way to get it is to follow Mikuro's post and instructions. But when I close out the "Terminal CharPaletteServe 80X24" it goes way. I can not us the normal functions to open it.

I have followed the instructions and help info, but for some reason I am missing certain options and boxes, they are just not there. I have the American Flag in view FWIW.

Thanks for any info that may help.
 

Satcomer

In Geostationary Orbit
OK it sounds like something is rEALLY messed up in you OS X. You ned to follow these steps to try to repair:

1. Determine you OS X version.

2. Go to Apple Downloads and install a combo update of you OS X version like the 10.5.5 combo.

3. Install the OS X version "Combo" of what you have.

4. The update will take a while to install it may restart your Mac twice. so get a cup of coffee or tea because it will take a while and may restart your Mac twice. It will take a while.

if this doesn't fix you problem then we may need to have you do an Archive & Install. This is like a total reinstall but it will preserve you applications and network settings. Hopefully we won't have to have you do this.
 

NoWake200

Registered
That did not change or fix the problem.

System Preferences (the one in the Dock)->International and once that opens pit check marks in "Character Palette" & "Keyboard Viewer". Then scroll down and put a check mark in your countries flag.

When I do this it does not give me the "Character Palette" option to check.

Once the flag of your country appears in the right hand corner (right next to the clock) you can click on it to drop it down and there you can start the Character Palette".


When I click on my flag there is not an option for "Character Palette".

Lastly, when I go to "Pages" and click Edit>Special Characters, nothing happens.

And the only way to open it up is through the Finder>Go>Go to Folder.

Thank you very much for trying to help me out!
 

Satcomer

In Geostationary Orbit
Well it sounds as if maybe a preference file or a menu cracker has been messed up.

Also open System Preferences (again)->International, then click on Input Menu tab and make sure a check mark is in (at the bottom) "Show input menu in menu bar". If it already there uncheck it, log out, log in and go back and put the check mark in there again.
 

Mikuro

Crotchety UI Nitpicker
Thanks for the reply. But for some reason this is not working. The only way to get it is to follow Mikuro's post and instructions. But when I close out the "Terminal CharPaletteServe 80X24" it goes way.

That much is normal. When you launch a program from Terminal, that Terminal window "owns" it, so you can't close the Terminal without shutting down the other program. You could hide or minimize Terminal if you want, though.



The only other idea I have that seems reasonable is to repair your disk permissions. I don't really expect it to work, but it can't hurt. In your /Applications/Utilities folder, open Disk Utility. Click on your disk in the list on the left, and then click the "Repair Disk Permissions" button. It'll take a few minutes. Once it's done, reboot your system, then go back into System Preferences and following the same instructions again.
 

NoWake200

Registered
Thanks for the reply, this is what I given.........


Repairing permissions for “Macintosh HD”
Reading permissions database.
Reading the permissions database can take several minutes.

Permissions differ on "private/var/log/secure.log", should be -rw------- , they are -rw-r----- .
Permissions differ on "Applications/Utilities/AirPort Utility.app/Contents/Resources/lanArrow.png", should be -rwxrwxr-x , they are -rw-rw-r-- .
Permissions differ on "Applications/Utilities/AirPort Utility.app/Contents/Resources/lanCheck.png", should be -rwxrwxr-x , they are -rw-rw-r-- .
Permissions differ on "Applications/Utilities/AirPort Utility.app/Contents/Resources/lanDisabled.png", should be -rwxrwxr-x , they are -rw-rw-r-- .
Permissions differ on "Applications/Utilities/AirPort Utility.app/Contents/Resources/wanArrow.png", should be -rwxrwxr-x , they are -rw-rw-r-- .
Permissions differ on "Applications/Utilities/AirPort Utility.app/Contents/Resources/wanCheck.png", should be -rwxrwxr-x , they are -rw-rw-r-- .
Permissions differ on "Applications/Utilities/AirPort Utility.app/Contents/Resources/wanDisabled.png", should be -rwxrwxr-x , they are -rw-rw-r-- .
Permissions differ on "System/Library/LaunchDaemons/com.apple.usbmuxd.plist", should be -rw-r--r-- , they are -rwxr-xr-x .
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Flags".
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Flowers".
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Fruit".
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Fung Shui".
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Funk Animals".
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Gems".
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Hollowbody Guitars".
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Planets".
ACL missing on "System/Library/User Template/da.lproj/Pictures/iChat Icons/Tribal Masks".
Group differs on "private/etc/cups", should be 0, group is 26.

Permissions repair complete
 

ora

Registered
Generally I run repair permissions again just to confirm I am permission problem free. That looks like a normal sort of permission repair result, though nothign that would affect the character map, but sometimes it fixes things anyway. Do it once a month or so at least.

Does the char palette work any better afterward though?
 
Top